О программе

 О программе Далее

Региональная информационная система предназначена для сбора данных на этапе подготовки ЕГЭ.

Информационная система поставляется в виде инсталляционного пакета.

Настоятельно рекомендуется ознакомиться с содержанием справки до начала работы с системой.

Оператор, отвечающий за подготовку данных должен ознакомиться с разделом Работа с программой. В этом разделе описана логика работы с программой и состав данных, который доступен для редактирования в разных организациях.

Администратору, настраивающему систему следует подробно изучить разделы «Установка программы», «Регистрация программы» и «Обновление программы».

При использовании сетевой версии программы следует изучить раздел «Менеджер соединений».


Установка программы

 О программе Назад Далее

Программа поставляется в виде инсталляционного пакета с именем setup_rcpi.v2_YYYY-MM-DD_HH-NN-SS.exe, где

· YYYY — год сборки пакета,
· MM — месяц сборки пакета,
· DD — день сборки пакета,
· HH — час сборки пакета,
· NN — минута сборки пакета,
· SS — секунда сборки пакета.

Для работы программы необходима операционная система Windows XP/Vista/W7. Пользователь, выполняющий установку, должен иметь права администратора системы. После установки с программой может работать любой пользователь, включенный в системную группу «Пользователи».

Для работы системы в операционной системе Linux необходимо установить эмулятор Windows API wine-1.3.10.

Рекомендуется устанавливать программу на компьютер с операционной системой Windows. Если в организации нет возможности установить программу на компьютер с операционной системой Windows, и программа будет использоваться на компьютере с операционной системой Linux, то перед установкой программы следует прочитать раздел «Особенности установки программы в операционной системе Linux».

Истялляционный пакет предусматривает 4 предопределенных варианта установки программы:

1. Локальная установка.Этот вариант установки следует использовать, если в организации будет использоваться одно рабочее место для работы с программой. При выборе данного варианта установки на компьютер будет установлена клиентская часть программы, встроенная СУБД FireBird 2.5, и база данных.
2. Сетевая установка (полная). При выборе данного варианта будет установлена база данных на указанный сервер и клиентская часть программы на рабочую станцию, на которой будет запущена программа установки. Для выполнения сетевой установки необходимо наличие установленной СУБД FireBird 2.5.
Этот вариант установки следует использовать, если:
1) в организации необходимо организовать несколько рабочих мест для работы с базой данных;
2) сетевая база данных еще не установлена;
3) нужно установить клиентскую часть на рабочую станцию.
3. Сетевая установка базы данных. При выборе данного варианта будет установлена база данных на указанный сервер. Для выполнения сетевой установки необходимо наличие установленной СУБД FireBird 2.5.
Этот вариант установки следует использовать, если:
1) в организации необходимо организовать несколько рабочих мест для работы с базой данных;
2) сетевая база данных еще не установлена;
3) не нужно устанавливать клиентскую часть на рабочую станцию.
4. Сетевая установка клиентской части. При выборе данного варианта будет установлена клиентская часть программы на рабочую станцию для работы с сетевой базой данной. Для выполнения сетевой установки необходимо наличие установленной СУБД FireBird 2.5.
Этот вариант установки следует использовать, если:
1) в организации необходимо организовать несколько рабочих мест для работы с базой данных;
2) сетевая база данных уже установлена;
3) нужно установить клиентскую часть на рабочую станцию.

Если пользователь при установке программы самостоятельно укажет компоненты (см., например, Сетевая установка (полная)), которые нужно установить, то вид установки автоматически переключится на «Пользовательская сетевая установка». В зависимости от набора выбранных к установке компонентов тип «Пользовательская сетевая установка» сводится к одному из четырех предопределенных видов, перечисленных выше.

Любой из трех видов сетевой установки требует наличия установленной СУБД FireBird 2.5. Об установке системы управления базами данных читайте раздел «Установка СУБД FireBird 2.5».


Локальная установка

Данный вид установки самый простой. При локальной установке на рабочую станцию устанавливается клиентская часть программы, база данных и встроенная СУБД FireBird 2.5.

Этот вид установки предназначен для организаций, в которых будет использоваться единственное рабочее место для работы с программой. Если необходимо организовать одновременную работу с базой на нескольких рабочих местах то перейдите к разделам сетевой установки программы.

Для того чтобы установить программу локально выполните следующие действия:

1. Скопируйте инсталляционный пакет setup_rcpi.v2_YYYY-MM-DD_HH-NN-SS.exe на жесткий диск рабочей станции.
2. Запустите скопированный файл на исполнение. Откроется окно «Приветствие мастера установки».

Приветствие мастера установки

3. В открывшемся окне нажмите кнопку Далее, будет открыто окно «Выбор вида установки».

Выбор вида установки

4. Выберите вид установки «Локальная установка», как это сделано на рисунке, и нажмите кнопку Далее. Будет открыто окно «Выбор папки установки программы».

Выбор папки установки программы

5. При необходимости выберите другую папку установки программы и нажмите кнопку Далее. Будет открыто окно « Параметры поиска обновлений ».

Параметры поиска обновлений

6. Укажите адрес для поиска обновлений программы. Адрес может отличаться от указанного на рисунке. Точный адрес будет сообщен региональным центром при раздаче инсталляционного пакета. Если на сервере обновлений будет требоваться авторизация, то дополнительно будет сообщено имя пользователя и пароль для доступа к серверу обновлений.
Если с рабочей станции, на которую устанавливается программа, выход в интернет осуществляется через proxy-сервер, то нужно указать параметры использования proxy-сервера. Модуль обновления на настоящий момент поддерживает только http тип и basic авторизацию при работе с proxy-сервером. Если используется иной тип proxy-сервера, то модуль обновления не будет работать.
Для подключения к интернет через proxy-сервер установите пометку Использовать proxy-сервер. Если proxy-сервер требует авторизацию, то укажите имя пользователя и пароль.
При использовании протокола FTP следует установить пометку Пассивный режим FTP.
По окончании настройки параметров обновления нажмите кнопку Далее, будет открыто окно «Выбор папки в меню «Пуск».

Выбор папки в меню «Пуск»

7. При необходимости укажите другую папку размещения ярлыков запуска. Нажмите кнопку Далее, откроется окно «Дополнительные задачи установки».

Дополнительные задачи установки

8. Если ярлык запуска программы не нужен на рабочем столе, то снимите пометку Создать ярлык на рабочем столе. Нажмите кнопку Далее, чтобы перейти к окну «Параметры установки».

Параметры установки

9. Ознакомьтесь со сводом параметров установки. Если это необходимо, то можно вернуться к предыдущим окнам для изменения параметров. Для этого необходимо нажимать кнопку Назад, пока не откроется нужное вам окно. Следует заметить, что пароли не отображаются в данном окне. Если все параметры указаны верно, то нажмите кнопку Установить, чтобы начать установку программы (см.«Индикатор процесса установки»).

Индикатор процесса установки

10. В конце установки будет запущен скрипт распаковки и установки базы данных, который будет выводить сообщения в консольное окно (см. Консоль сообщений скрипта установки БД ). В консоли будет отображаться подробный лог установки базы данных. Данный лог записывается и в файл, в папку установки программы в подпапку backups.
Если инсталлятор обнаружит уже установленную базу данных в папке назначения, то вначале будет создана резервная копия базы данных, которая запишется в папку установки программы в подпапку backups. (часть лога резервного копирования как раз и представлена на рисунке).
А после резервного копирования будет произведено обновление базы данных до новой версии.
Если же в папке назначения рабочей базы обнаружена не будет, то будет восстановлена новая база данных из инсталляционного пакета.

Консоль сообщений скрипта установки БД

11. Если в процессе установки базы данных, или в процессе обновления существующей базы данных до новой версии произойдет ошибка, то мастер установки выведет на окно сообщение с ошибкой и путь до файла, в котором содержится подробный лог процесса установки базы данных (см. пример окна «Сообщение об ошибке»).

Сообщение об ошибке установки БД

Запишите или запомните расположение лога установки БД. Он потребуется для анализа ошибки и разрешения ситуации. Если БД не удалось развернуть, то установка будет отменена, о чем будет сообщено при закрытии окна ошибки (см. «Установка не возможна») .

Установка не возможна

Если вы выполняли повторную установку, и существовала база данных в папке назначения, то будет запущен процесс восстановления БД из резервной копии. Процесс восстановления БД будет отражаться в консольном окне «Восстановление БД из резервной копии»

Восстановление БД из резервной копии

12. Если процесс установки прошел успешно, то будет выведено окно «Завершение установки»

Завершение установки


Сетевая установка (полная)

Данный вид установки требует наличия в локальной сети установленной СУБД FireBird 2.5. В СУБД FireBird 2.5 необходимо создать пользователя, от имени которого будет установлена база данных и который будет владельцем БД. Все административные операции с базой данной нужно будет выполнять от имени этого пользователя.

Если имеется установленная и настроенная СУБД FireBird 2.5, то можно выполнить полную сетевую установку программы.

Полная сетевая установка предназначена для установки клиентской части на рабочую станцию и развертывания базы данных в локальной сети.

Для выполнения полной сетевой установки выполните следующие шаги:

1. Скопируйте инсталляционный пакет setup_rcpi.v2_YYYY-MM-DD_HH-NN-SS.exe на жесткий диск рабочей станции.
2. Запустите скопированный файл на исполнение. Откроется окно «Приветствие мастера установки».

Приветствие мастера установки

3. В открывшемся окне нажмите кнопку Далее, будет открыто окно «Выбор вида установки»

Выбор вида установки

4. Выберите вид установки «Сетевая установка (полная)», как это сделано на рисунке, и нажмите кнопку Далее. Будет открыто окно «Выбор папки установки программы».

Выбор папки установки программы

5. При необходимости выберите другую папку установки программы и нажмите кнопку Далее. Будет открыто окно «Параметры подключения к БД».

Параметры подключения к БД

6. В окне параметров соединения с сетевой базой данных укажите:
- DNS-имя или IP-адрес сервера, на котором установлена СУБД FireBird 2.5;
- порт подключения к СУБД FireBird 2.5, если он был изменен при установке СУБД;
- алиас БД (если в конфигурационном файле СУБД FireBird 2.5 прописан алиас) или полный путь в файловой системе сервера до файла БД (путь должен существовать);
- имя пользователя для работы с БД (пользователь предварительно должен быть создан средствами СУБД);
- пароль пользователя (и подтверждения пароля);
- роль для работы с БД, соответствующую типу организации, в которой устанавливается программа.
После заполнения всех полей нажмите кнопку Далее для перехода к окну «Выбор папки хранения резервных копий».

Выбор папки хранения резервных копий

7. Данное окно позволяет определить в какой папке создать резервную копию базы данных, если делается повторная установка базы данных, т.е. если указанные вами параметры подключения к БД указывают на уже развернутую базу данных.
Следует отметить, что резервная копия БД создается на компьютере, на котором запущен инсталляционный пакет.
При необходимости измени местоположение сохранения резервной копии и нажмите кнопку Далее для перехода к окну «Параметры поиска обновлений».

Параметры поиска обновлений

8. Укажите адрес для поиска обновлений программы. Адрес может отличаться от указанного на рисунке. Точный адрес будет сообщен региональным центром при раздаче инсталляционного пакета. Если на сервере обновлений будет требоваться авторизация, то дополнительно будет сообщено имя пользователя и пароль для доступа к серверу обновлений.
Если с рабочей станции, на которую устанавливается программа, выход в интернет осуществляется через proxy-сервер, то нужно указать параметры использования proxy-сервера. Модуль обновления на настоящий момент поддерживает только http тип и basic авторизацию при работе с proxy-сервером. Если используется иной тип proxy-сервера, то модуль обновления не будет работать.
Для подключения к интернет через proxy-сервер установите пометку Использовать proxy-сервер. Если proxy-сервер требует авторизацию, то укажите имя пользователя и пароль.
При использовании протокола FTP следует установить пометку Пассивный режим FTP.
По окончании настройки параметров обновления нажмите кнопку Далее, будет открыто окно «Выбор папки в меню «Пуск».

Выбор папки в меню «Пуск»

9. При необходимости укажите другую папку размещения ярлыков запуска. Нажмите кнопку Далее, откроется окно «Дополнительные задачи установки».

Дополнительные задачи установки

10. Если ярлык запуска программы не нужен на рабочем столе, то снимите пометку Создать ярлык на рабочем столе. Нажмите кнопку Далее, чтобы перейти к окну «Параметры установки».

Параметры установки

11. Ознакомьтесь со сводом параметров установки. Если это необходимо, то можно вернуться к предыдущим окнам для изменения параметров. Для этого необходимо нажимать кнопку Назад, пока не откроется нужное вам окно. Следует заметить, что пароли не отображаются в данном окне. Если все параметры указаны верно, то нажмите кнопку Установить, чтобы начать установку программы (см.«Индикатор процесса установки»)

Индикатор процесса установки

12. В конце установки будет запущен скрипт распаковки и установки базы данных, который будет выводить сообщения в консольное окно (см. Консоль сообщений скрипта установки БД ). В консоли будет отображаться подробный лог установки базы данных. Данный лог записывается и в файл, в папку указанную в окне «Выбор папки хранения резервных копий».
Если инсталлятор обнаружит уже установленную базу данных по указанным вами параметрам подключения (Параметры подключения к БД), то вначале будет создана резервная копия базы данных, которая запишется в папку указанную в окне «Выбор папки хранения резервных копий» (часть лога резервного копирования как раз и представлена на рисунке).
После резервного копирования будет произведено обновление базы данных до новой версии.
Если же рабочей базы обнаружено не будет, то будет восстановлена новая база данных из инсталляционного пакета.

Консоль сообщений скрипта установки БД

13. Если в процессе установки базы данных, или в процессе обновления существующей базы данных до новой версии произойдет ошибка, то мастер установки выведет на окно сообщение с ошибкой и путь до файла, в котором содержится подробный лог процесса установки базы данных (см. пример окна «Сообщение об ошибке»).

Сообщение об ошибке установки БД

Запишите или запомните расположение лога установки БД. Он потребуется для анализа ошибки и разрешения ситуации. Если БД не удалось развернуть, то установка будет отменена, о чем будет сообщено при закрытии окна ошибки (см. «Установка не возможна») .

Установка не возможна

Если в процессе установки делалось резервное копирование существующей базы данных, то будет запущен процесс восстановления БД из резервной копии. Процесс восстановления БД будет отражаться в консольном окне «Восстановление БД из резервной копии»

Восстановление БД из резервной копии

14. Если процесс установки прошел успешно, то будет выведено окно «Завершение установки»

Завершение установки


Сетевая установка базы данных

Данный вид установки требует наличия в локальной сети установленной СУБД FireBird 2.5. В СУБД FireBird 2.5 необходимо создать пользователя, от имени которого будет установлена база данных и который будет владельцем БД. Все административные операции с базой данной нужно будет выполнять от имени этого пользователя.

Если имеется установленная и настроенная СУБД FireBird 2.5, то можно выполнить сетевую установку базы данных.

Сетевая установка базы данных предназначена для развертывания в локальной сети БД, доступ к которой можно будет осуществлять с разных рабочих станций.

Для выполнения сетевой установки базы данных выполните следующие шаги:

1. Скопируйте инсталляционный пакет setup_rcpi.v2_YYYY-MM-DD_HH-NN-SS.exe на жесткий диск рабочей станции.
2. Запустите скопированный файл на исполнение. Откроется окно «Приветствие мастера установки».

Приветствие мастера установки

3. В открывшемся окне нажмите кнопку Далее, будет открыто окно «Выбор вида установки»

Выбор вида установки

4. Выберите вид установки «Сетевая установка базы данных», как это сделано на рисунке, и нажмите кнопку Далее. Будет открыто окно «Параметры подключения к БД».

Параметры подключения к БД

5. В окне параметров соединения с сетевой базой данных укажите:
- DNS-имя или IP-адрес сервера, на котором установлена СУБД FireBird 2.5;
- порт подключения к СУБД FireBird 2.5, если он был изменен при установке СУБД;
- алиас БД (если в конфигурационном файле СУБД FireBird 2.5 прописан алиас) или полный путь в файловой системе сервера до файла БД (путь должен существовать);
- имя пользователя для работы с БД (пользователь предварительно должен быть создан средствами СУБД);
- пароль пользователя (и подтверждение пароля);
- роль для работы с БД, соответствующую типу организации, в которой устанавливается программа.
После заполнения всех полей нажмите кнопку Далее для перехода к окну «Выбор папки хранения резервных копий».

Выбор папки хранения резервных копий

6. Данное окно позволяет определить в какой папке создать резервную копию базы данных, если делается повторная установка базы данных, т.е. если указанные вами параметры подключения к БД указывают на уже развернутую базу данных.
Следует отметить, что резервная копия БД создается на компьютере, на котором запущен инсталляционный пакет.
При необходимости измени местоположение сохранения резервной копии и нажмите кнопку Далее для перехода к окну «Параметры установки».

Параметры установки

7. Ознакомтесь со сводом параметров установки. Если это необходимо, то можно вернуться к предыдущим окнам для изменения параметров. Для этого необходимо нажимать кнопку Назад, пока не откроется нужное вам окно. Следует заметить, что пароли не отображаются в данном окне. Если все параметры указаны верно, то нажмите кнопку Установить, чтобы начать установку программы (см.«Индикатор процесса установки»)

Индикатор процесса установки

8. В конце установки будет запущен скрипт распаковки и установки базы данных, который будет выводить сообщения в консольное окно (см. Консоль сообщений скрипта установки БД ). В консоли будет отображаться подробный лог установки базы данных. Данный лог записывается и в файл, в папку указанную в окне «Выбор папки хранения резервных копий».
Если инсталлятор обнаружит уже установленную базу данных по указанным вами параметрам подключения (Параметры подключения к БД), то вначале будет создана резервная копия базы данных, которая запишется в папку указанную в окне «Выбор папки хранения резервных копий» (часть лога резервного копирования как раз и представлена на рисунке).
После резервного копирования будет произведено обновление базы данных до новой версии.
Если же рабочей базы обнаружено не будет, то будет восстановлена новая база данных из инсталляционного пакета.

Консоль сообщений скрипта установки БД

9. Если в процессе установки базы данных, или в процессе обновления существующей базы данных до новой версии произойдет ошибка, то мастер установки выведет на окно сообщение с ошибкой и путь до файла, в котором содержится подробный лог процесса установки базы данных (см. пример окна «Сообщение об ошибке»).

Сообщение об ошибке установки БД

Запишите или запомните расположение лога установки БД. Он потребуется для анализа ошибки и разрешения ситуации. Если БД не удалось развернуть, то установка будет отменена, о чем будет сообщено при закрытии окна ошибки (см. «Установка не возможна») .

Установка не возможна

Если в процессе установки делалось резервное копирование существующей базы данных, то будет запущен процесс восстановления БД из резервной копии. Процесс восстановления БД будет отражаться в консольном окне «Восстановление БД из резервной копии»

Восстановление БД из резервной копии

10. Если процесс установки прошел успешно, то будет выведено окно «Завершение установки»

Завершение установки


Сетевая установка клиентской части

Данный вид установки предусматривает, что база данных уже развернута в локальной сети.

Сетевая установка клиентской части предназначена для настройки рабочего места работы с сетевой базой данных.

Для выполнения сетевой установки клиентской части выполните следующие шаги:

1. Скопируйте инсталляционный пакет setup_rcpi.v2_YYYY-MM-DD_HH-NN-SS.exe на жесткий диск рабочей станции.
2. Запустите скопированный файл на исполнение. Откроется окно «Приветствие мастера установки».

Приветствие мастера установки

3. В открывшемся окне нажмите кнопку Далее, будет открыто окно «Выбор вида установки»

Выбор вида установки

4. Выберите вид установки «Сетевая установка клиентской части», как это сделано на рисунке, и нажмите кнопку Далее. Будет открыто окно «Выбор папки установки программы».

Выбор папки установки программы

5. При необходимости выберите другую папку установки программы и нажмите кнопку Далее. Будет открыто окно «Параметры подключения к БД».

Параметры подключения к БД

6. В окне параметров соединения с сетевой базой данных укажите:
- DNS-имя или IP-адрес сервера, на котором установлена СУБД FireBird 2.5;
- порт подключения к СУБД FireBird 2.5, если он был изменен при установке СУБД;
- алиас БД (если в конфигурационном файле СУБД FireBird 2.5 прописан алиас) или полный путь в файловой системе сервера до файла БД (путь должен существовать);
- имя пользователя для работы с БД (пользователь предварительно должен быть создан средствами СУБД);
- пароль пользователя (и подтверждение пароля);
- роль для работы с БД, соответствующую типу организации, в которой устанавливается программа.
После заполнения всех полей нажмите кнопку Далее для перехода к окну «Параметры поиска обновлений».

Параметры поиска обновлений

7. Укажите адрес для поиска обновлений программы. Адрес может отличаться от указанного на рисунке. Точный адрес будет сообщен региональным центром при раздаче инсталляционного пакета. Если на сервере обновлений будет требоваться авторизация, то дополнительно будет сообщено имя пользователя и пароль для доступа к серверу обновлений.
Если с рабочей станции, на которую устанавливается программа, выход в интернет осуществляется через proxy-сервер, то нужно указать параметры использования proxy-сервера. Модуль обновления на настоящий момент поддерживает только http тип и basic авторизацию при работе с proxy-сервером. Если используется иной тип proxy-сервера, то модуль обновления не будет работать.
Для подключения к интернет через proxy-сервер установите пометку Использовать proxy-сервер. Если proxy-сервер требует авторизацию, то укажите имя пользователя и пароль.
При использовании протокола FTP следует установить пометку Пассивный режим FTP.
По окончании настройки параметров обновления нажмите кнопку Далее, будет открыто окно «Выбор папки в меню «Пуск».

Выбор папки в меню «Пуск»

8. При необходимости укажите другую папку размещения ярлыков запуска. Нажмите кнопку Далее, откроется окно «Дополнительные задачи установки».

Дополнительные задачи установки

9. Если ярлык запуска программы не нужен на рабочем столе, то снимите пометку Создать ярлык на рабочем столе. Нажмите кнопку Далее, чтобы перейти к окну «Параметры установки».

Параметры установки

10. Ознакомтесь со сводом параметров установки. Если это необходимо, то можно вернуться к предыдущим окнам для изменения параметров. Для этого необходимо нажимать кнопку Назад, пока не откроется нужное вам окно. Следует заметить, что пароли не отображаются в данном окне. Если все параметры указаны верно, то нажмите кнопку Установить, чтобы начать установку программы (см.«Индикатор процесса установки»)

Индикатор процесса установки

11. Если процесс установки прошел успешно, то будет выведено окно «Завершение установки»

Завершение установки


Особенности установки программы в операционной системе Linux

Для того чтобы установить программу в операционной системе Linux нужен установленный эмулятор Windows API. В качестве эмулятора следует использовать wine-1.3.10 либо более позднюю версию.

В ранних версиях эмулятора WINE для корректной работы программы требуется установить библиотеки MSXML и WinInet от Microsoft. Если библиотеки работы с XML распространяются бесплатно, то использование библиотеки WinInet требует наличия лицензии на операционную систему Windows. Поэтому рекомендуется использовать самую свежую версию WINE скомплированную из исходных кодов.

Сетевая версия программы требует предварительной установки СУБД FireBird 2.5. Дистрибутив СУБД для вашей версии Linux можно найти по адресу http://sourceforge.net/projects/firebird. Готовый инсталляционный пакет для Linux устанавливает СУБД FireBird 2.5 в предопределенную папку и не позволяет установить две версии СУБД на одном компьютере. Если у вас на сервере уже установлена СУБД FireBird версия которой отлична от СУБД FireBird 2.5, то необходимо собрать инсталляционный пакет из исходных кодов с новыми параметрами установки. За дополнительной информацией по установке СУБД FireBird 2.5 на Linux обратитесь к документации http://www.firebirdsql.org/manual/ufb-cs-embedded.html (HTML) или http://www.firebirdsql.org/pdfmanual/Using-Firebird_(wip).pdf (PDF).


Установка СУБД FireBird 2.5

Сетевая версия программы требует предварительной установки СУБД FireBird 2.5. Дистрибутив СУБД для вашей версии операционной системы можно найти по адресу http://sourceforge.net/projects/firebird.

Установка СУБД в операционной системе Windows интуитивно понятна. Тем не менее, необходимо ознакомиться с документацией по установке СУБД. Документацию можно получить по адресу http://www.firebirdsql.org/manual/ufb-cs-embedded.html (HTML) или http://www.firebirdsql.org/pdfmanual/Using-Firebird_(wip).pdf (PDF).

При установке СУБД на платформе Linux есть некоторые особенности. Готовый инсталляционный пакет для Linux устанавливает СУБД FireBird 2.5 в предопределенную папку и не позволяет установить две версии СУБД на одном компьютере. Если у вас на сервере уже установлена СУБД FireBird версия которой отлична от СУБД FireBird 2.5, то необходимо собрать инсталляционный пакет из исходных кодов с новыми параметрами установки, либо установить СУБД FireBird 2.5 на другой компьютер. За дополнительной информацией по установке СУБД FireBird 2.5 на Linux обратитесь к документации.

После установки СУБД FireBird 2.5 следует создать пользователя от имени которого будет устанавливаться база данных. Все административные операции с БД нужно выполнять от имени пользователя, под которым производилась установка БД.

Кроме того необходимо изменить пароль суперпользователя SYSDBA. Не следует использовать «умолчательный» пароль суперпользователя.


Работа с программой

В работе с программой можно выделить несколько видов деятельности:

1. Установка программы.
Установку программы следует выполнять квалифицированному специалисту, имеющему опыт установки и настройки программ. Тем не менее, локальная установка не требует от пользователя никаких особых навыков и может быть выполнена любым пользователем с административными правами.
2. Регистрация программы.
Регистрация необходима для настройки программы на работу в организации. Без регистрации не будет работать экспорт данных.
3. Ввод и редактирование данных.
Состав данных, доступный для редактирования, зависит от типа организации, на которую зарегистрирована программа (см. таблицу). Следует отметить, что на дополнительном этапе (июльский этап) обмен данными осуществляется между РЦОИ, ППЭ и ОУ. Для обмена используется текстовый файл заданного формата. Более подробно обмен данными на дополнительном этапе описан в разделе импорта и экспорта.

Тип организации

Редактируемые данные

Рекомендации по заполнению

Данные для экспорта

Образовательное учреждение
· данные ОУ,
· данные по учителям (включая список ролей, которые он может исполнять в пункте проведения экзамена),
· данные по ученикам образовательного учреждения.
· Рекомендуется изменять данные об образовательном учреждении на уровне ОУ.
· При редактировании по учителям следует указать все роли, которые учитель может исполнять в ППЭ. Список ролей заполняется на тех учителей, которые будут участвовать в проведении экзамена.
· У образовательном учреждении следует регистрировать только тех учащихся, которые являются выпускниками ОУ этого года. Всех «чужих» (выпускников НПО, выпускников прошлых лет) следует регистрировать в «виртуальных» школах в МОУО.

При экспорте из базы данных, зарегистрированной на ОУ, в файл экспорта могут быть выгружены:

· сведения по образовательному учреждению,
· сведения по учителям,
· сведения по учащимся.

Муниципальный орган управления образованием (регистрация программы производится на АТЕ, на территории которой располагается МОУО)
· данные АТЕ,
· данные МОУО,
· данные по ОУ,
· данные по учителям (включая список ролей, которые он может исполнять в пункте проведения экзамена),
· данные по ученикам образовательного учреждения,
· данные по ППЭ района,
· данные по работникам ППЭ.
· В МОУО необходимо отредактировать данные АТЕ и МОУО.
· В МОУО должны регистрироваться все выпускники прошлых лет. Эти участники регистрируются в «виртуальных» школах АТЕ. В каждом АТЕ в список ОУ добавлена виртуальная школа «ВПЛ — <название района>».
· Список ППЭ и привязки ОУ к ППЭ на каждый экзамен составляются в МОУО.
· Список работников ППЭ можно будет сформировать на основе данных по учителям, при условии, что в ОУ будет заполняться список ролей.
· Все остальные данные должны заполняться в ОУ и ППЭ и предаваться в МОУО в виде экспортных файлов.

При экспорте из базы данных, зарегистрированной на МОУО, в файл экспорта могут быть выгружены:

· сведения по текущему АТЕ,
· сведения по муниципальному органу управления образованием,
· сведения по образовательным учреждениям района,
· сведения по учителям ОУ района,
· сведения по участникам, зарегистрированным в ОУ района,
· сведения по ППЭ района,
· сведения по работникам ППЭ,
· сведения по распределению экзаменуемых и работников на экзамены.

Пункт проведения экзамена
· данные ППЭ,
· данные работников ППЭ,
· анкетные данные экзаменуемых.
· Список работников ППЭ является общим для всех ППЭ района. Поэтому, если сведения по работникам изначально собираются в пунктах проведения экзамена, то после передачи данных по работникам в МОУО следует проверить список на предмет дублирования данных. После каждого экзамена список работников может изменяться. Поэтому после сбора данных по распределению со всех пунктов проведения экзаменов следует передать полный обновленный список из МОУО во все ППЭ района.
· Запись экзаменуемых и работников на конекретный экзамен должна выполняться и в МОУО, а затем передаваться в ППЭ в файлах экспорта.
· При экспорта данных распределения на экзамен в файл выгружаются и анкетные данные экзаменуемых и работников задействованных в проведении экзамена. Поэтому, если в анкетных данных были сделаны изменения (например, изменены данные документа или добавлен новый работник ППЭ), то эти изменения автоматически попадают в файл экспорта.
· данные ППЭ,
· данные по распределению, включая анкетные данные работников и экзаменуемых.

Вообще говоря, на уровне ОУ доступны все справочники для редактирования, но при выгрузке данных в файл будут попадать только те данные, редактирование которых предусмотрено в ОУ. Данный тезис справедлив и для всех остальных организаций.

4. Экспорт данных.
Экспорт данных предназначен для выгрузки данных из БД в файл, для передачи в другую организацию. Состав экспортируемых данных описан в п. 3 данного раздела.
5. Импорт данных.
Данная операция предназначена для загрузки данных из файла в БД для дальнейшей обработки.


Регистрация программы

Регистрация необходима для настройки программы на работу в организации. Без регистрации не будет работать экспорт данных. О регистрации программы необходимо знать следующее:

1. Регистрационные данные записываются в базу данных. После внесения регистрационных данных в базу изменить их стандартными средствами программы нельзя.
2. Для регистрации программы на организацию необходимо выполнить импорт файла организации.
3. Для АТЕ формируются файлы с именем ARE_XXXXXX.EXP, где XXXXXX — код АТЕ.
Для ОУ формируются файлы с именем SCH_XXXXXX.EXP, где XXXXXX — код ОУ.
Для ППЭ формируются файлы с именем STN_XXXXXX.EXP, где XXXXXX — код ППЭ.
4. В каждом файле, сформированном программой для организации (подробнее см. экспорт данных), содержится тип и код организации, на которую должна быть зарегистрирована база данных.
5. Регистрация происходит при импорте первого файла, если регистрационные данные еще не были внесены в БД.
6. При выполнении импорта в зарегистрированную базу данных регистрационная информация меняться не будет.

Итак, для регистрации программы:

1. Получите у вышестоящей организации файл, созданных для вашей организации. (Для МОУО файлы формируются в РЦОИ, для ОУ и ППЭ — в МОУО).
2. Запустите процедуру импорта файла.
3. В списке импортируемых данных установите пометку «Регистрационные данные».
4. Выполните импорт данных.
5. Откройте пункт меню ?—Регистрация, чтобы убедиться, что регистрация выполнена.


Ввод и редактирование данных

Программа сбора данных по ЕГЭ и ГИА9 представляет собой модульный комплекс. За выполнение отдельной задачи отвечает специализированный модуль. Доступ к модулям, реализующим пользовательский интерфейс работы с данными, предоставляется посредством пунктов меню в основном окне программы.

Основное окно программы

Пункт меню Файл обеспечивает доступ к функциям импорта и экспорта данных.

Пункт меню «Файл»

Пункт меню Модули обеспечивает доступ к различным справочникам. Подробнее по работе со справочниками читайте в подразделах, названия которых соответствуют названиям пунктов меню.

Пункт меню «Модули»

Пункт меню Настройки обеспечивает вызов функций настройки программы.

Пункт меню «Настройки»

Пункт меню Окна позволяет переключиться в открытый справочник, либо закрыть текущий справочник.

Пункт меню «Окна»

Пункт меню ? позволяет просмотреть регистрационные данные (подпункт Регистрация), открыть справку по программе (подпункт Содержание), выполнить обновление программы или настроить параметры обновления.

Пункт меню «?»


Справочник АТЕ

Справочник АТЕ предназначен для редактирования данных по административно-территориальным единицам.

Редактирование данных АТЕ следует выполнять в МОУО. В образовательном учреждении редактирование данных по АТЕ доступно, но выгружаться измененные данные в файл не будут.

Открыть справочник можно выбрав пункт меню Модули—Справочник АТЕ. В файлах экспорта ARE_XXXXXX.EXP и SCH_XXXXXX.EXP содержатся данные только по одной АТЕ, поэтому в справочнике будет только одна запись, если вы будете загружать файлы организаций своего района (см. рисунок Справочник АТЕ).

Справочник АТЕ

В окне можно изменять ширину колонок списков. Для этого нужно навести курсор мыши на границу колонок в заголовке окна, нажать левую клавишу мыши и, перемещая указатель мыши, изменить ширину колонки.

Изменение ширины колонок в списке АТЕ

Изменение ширины колонок в данных по АТЕ

Аналогичным образом можно изменять ширину списка АТЕ

Изменение ширины списка

Вы можете изменять высоту списка атрибутов АТЕ. Для этого нужно навести курсор мыши на нижнюю границу списка, нажать левую клавишу мыши, и перемещая указатель вверх или вниз, изменить высоту списка.

Изменение высоты списка атрибутов


Редактирование данных АТЕ

Для изменения данных по АТЕ необходимо выполнить следующие действия:

1. В справочнике АТЕ выбрать название АТЕ, данные которого нужно изменить.

Выбор АТЕ для редактирования данных
2. Выбрать пункт меню Данные—Изменить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+E. Будет открыто окно редактирования данных АТЕ.

\Окно редактирования данных АТЕ
На странице Основные сведения вносятся следующие данные:
Код АТЕ — код района. Данное поле не доступно для изменения.
Полное наименование АТЕ — название района. Данное поле не доступно для изменения.
Наименование муниципального органа самоуправления — следует внести название соответствующее уставным документам.
Юридический адрес муниципального органа самоуправления — укажите юридический адрес, согласно уставным документам.
Фактический адрес муниципального органа самоуправления — укажите фактический адрес, если он отличается от юридического.
ФИО руководителя муниципального органа самоуправления.
Телефоны муниципального органа самоуправления — телефоны указываются через запятую, каждый телефон записывается в формате (<код>) <номер телефона>. Пробелы и тире в коде и номере телефона не ставятся.
Факсы муниципального органа самоуправления — номера указываются через запятую, каждый номер записывается в формате (<код>) <номер факса>. Пробелы и тире в коде и номере телефона не ставятся.
Адреса электронной почты муниципального органа самоуправления — можно указать несколько адресов через точку с запятой.
Должность ответственного за ЕГЭ — должность специалиста отвечающего за организацию и проведение ЕГЭ в районе.
ФИО ответственного за ЕГЭ — фамилия имя и отчество специалиста отвечающего за организацию и проведение ЕГЭ в районе.
Телефоны ответственного за ЕГЭ — номера указываются через запятую, каждый номер записывается в формате (<код>) <номер телефона>. Пробелы и тире в коде и номере телефона не ставятся.
Адреса электронной почты ответственного за ЕГЭ — можно указать несколько адресов через точку с запятой.
3. Исправив данные на странице основных сведений переключитесь на страницу Дополнительные сведения.

Дополнительные сведения по АТЕ
На станице дополнительных сведений указываются следующие данные:
Численность населения — укажите численность населения района.
Площадь — укажите площадь района.
Расстояние до ближайшей Ж/Д станции — укажите расстояние в километрах от районного цента до ближайшей железнодорожной станции.
Расстояние до регионального цента — укажите расстояние в километрах от районного цента до г. Барнаула.
Численность населения административного центра — укажите численность населения районного центра.
4. Заполнив все поля формы актуальными данными нажмите кнопку Сохранить. Все сведения будут записаны в базу данных.


Справочник МОУО

Справочник МОУО предназначен для редактирования данных муниципальных органов управления образованием.

Редактирование данных МОУО следует выполнять в МОУО. В образовательном учреждении редактирование данных по МОУО доступно, но выгружаться измененные данные в файл не будут.

Открыть справочник можно выбрав пункт меню Модули—Справочник МОУО. В файлах экспорта ARE_XXXXXX.EXP и SCH_XXXXXX.EXP содержатся данные по всем МОУО края (см. рисунок Справочник МОУО).

Справочник МОУО

В окне можно изменять ширину колонок списков. Для этого нужно навести курсор мыши на границу колонок в заголовке окна, нажать левую клавишу мыши и, перемещая указатель мыши, изменить ширину колонки.

Изменение ширины колонок в списке МОУО

Изменение ширины колонок в данных по МОУО

Аналогичным образом можно изменять ширину списка МОУО

Изменение ширины списка

Вы можете изменять высоту списка атрибутов МОУО. Для этого нужно навести курсор мыши на нижнюю границу списка, нажать левую клавишу мыши, и перемещая указатель вверх или вниз, изменить высоту списка.

Изменение высоты списка атрибутов


Редактирование данных МОУО

Для изменения данных по МОУО необходимо выполнить следующие действия:

1. В справочнике МОУО выбрать название МОУО, данные которого нужно изменить.

Выбор МОУО для редактирования данных
2. Выбрать пункт меню Данные—Изменить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+E. Будет открыто окно редактирования данных МОУО.

Окно редактирования данных МОУО
На странице Данные о МОУО вносятся следующие данные:
Код МОУО — код муниципального органа управления образованием. Данное поле не доступно для изменения.
Тип МОУО — все МОУО районов должны иметь статус «муниципальный ОУО».
Полное наименование МОУО — название МОУО согласно уставным документам.
Тип населенного пункта — типа населенного пункта, на территории которого располагается МОУО.
Юридический адрес МОУО — укажите юридический адрес, согласно уставным документам.
Фактический адрес МОУО — укажите фактический адрес, если он отличается от юридического.
Телефоны МОУО — телефоны указываются через запятую, каждый телефон записывается в формате (<код>) <номер телефона>. Пробелы и тире в коде и номере телефона не ставятся.
Факсы МОУО — номера указываются через запятую, каждый номер записывается в формате (<код>) <номер факса>. Пробелы и тире в коде и номере факса не ставятся.
Адреса электронной почты МОУО — можно указать несколько адресов через точку с запятой.
WWW-сайт МОУО — адрес WWW-сервера муниципального органа управления образованием.
ИНН — ИНН МОУО.
КПП — КПП МОУО.
Расчетный счет — расчетный счет МОУО в банке.
Корреспондирующий счет — корр. счет МОУО в банке.
Название банка — наименование банка, в котором открыт счет МОУО.
Город банка — город, в котором располагается банк.
БИК банка — БИК банка, в котором открыт счет МОУО.
Количество дошкольных ОУ.
Количество начальных ОУ.
Количество основных ОУ.
Количество средних ОУ.
Количество вспомогательных ОУ.
3. Исправив данные на странице основных сведений переключитесь на страницу Данные о МОУО (специалисты).

Сведения о специалистах МОУО
На станице дополнительных сведений указываются следующие данные:
Должность руководителя МОУО.
ФИО руководителя МОУО.
Телефоны руководителя МОУО — номера указываются через запятую, каждый номер записывается в формате (<код>) <номер телефона>. пробелы и тире в коде и номере телефона не ставятся.
Адреса электронной почты руководителя МОУО — можно указать несколько адресов через точку с запятой.
Должность ответственного за ЕГЭ.
ФИО ответственного за ЕГЭ.
Телефоны ответственного за ЕГЭ — номера указываются через запятую, каждый номер записывается в формате (<код>) <номер телефона>. пробелы и тире в коде и номере телефона не ставятся.
Адреса электронной почты ответственного за ЕГЭ — можно указать несколько адресов через точку с запятой.
Должность специалиста по программно-техническому обеспечению.
ФИО специалиста по программно-техническому обеспечению.
Телефоны специалиста по программно-техническому обеспечению — номера указываются через запятую, каждый номер записывается в формате (<код>) <номер телефона>. пробелы и тире в коде и номере телефона не ставятся.
Адреса электронной почты специалиста по программно-техническому обеспечению — можно указать несколько адресов через точку с запятой.
Должность специалиста по книгам.
ФИО специалиста по книгам.
Телефоны специалиста по книгам — номера указываются через запятую, каждый номер записывается в формате (<код>) <номер телефона>. пробелы и тире в коде и номере телефона не ставятся.
Адреса электронной почты специалиста по книгам — можно указать несколько адресов через точку с запятой.
4. Заполнив все поля формы актуальными данными нажмите кнопку Сохранить. Все сведения будут записаны в базу данных.


Справочник ОУ

Справочник УО предназначен для редактирования данных образовательных учреждений.

Редактирование данных ОУ следует выполнять в ОУ.

Открыть справочник можно выбрав пункт меню Модули—Справочник ОУ. В файлах экспорта ARE_XXXXXX.EXP содержатся данные по всем ОУ района. В файлах SCH_XXXXXX.EXP содержатся данные только по ОУ, для которого предназначен файл. В каждом районе добавлена одна «виртуальная школа». Название такого ОУ задано по шаблону «ВПЛ-<Название района>». Виртуальные школы предназначены для регистрации выпускников прошлых лет. В невиртуальных ОУ следует регистрировать только выпускников.

Справочник ОУ

В окне можно изменять ширину колонок списков. Для этого нужно навести курсор мыши на границу колонок в заголовке окна, нажать левую клавишу мыши и, перемещая указатель мыши, изменить ширину колонки.

Изменение ширины колонок в списке ОУ

Изменение ширины колонок в данных по ОУ

Изменение ширины колонок в списке количества учащихся

Аналогичным образом можно изменять ширину дерева АТЕ и списка ОУ

Изменение ширины дерева АТЕ

Изменение ширины списка ОУ

Вы можете изменять высоту списка атрибутов ОУ. Для этого нужно навести курсор мыши на нижнюю границу списка, нажать левую клавишу мыши, и перемещая указатель вверх или вниз, изменить высоту списка.

Изменение высоты списка атрибутов

Пункт меню Вид или кнопка [image] на панели инструментов позволяют скртыть/отобразить дерево АТЕ.


Редактирование данных ОУ

Для изменения данных по ОУ необходимо выполнить следующие действия:

1. В справочнике ОУ выбрать название ОУ, данные которого нужно изменить.

Выбор МОУО для редактирования данных
2. Выбрать пункт меню Данные—Изменить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+E. Будет открыто окно редактирования данных ОУ.

Окно редактирования данных ОУ
На странице Основные сведения вносятся следующие данные:
Код ОУ — код образовательного учреждения. Данное поле не доступно для изменения.
Краткое наименование ОУ — Краткое наименование используется программой для отображения названия ОУ в различных формах просмотра и редактирования данных.
Полное наименование ОУ — название ОУ согласно уставным документам. Полное наименование используется в отчетах, формируемых программой.
Орган управления образованием — МОУО к которому относится образовательное учреждение. Данное поле не доступно для редактирования.
Организационно-правовая форма ОУ — укажите организационно-правовую форму в соответствии с уставными документами.
Тип ОУ — укажите тип образовательного учреждения в соответствии с уставными документами.
Вид ОУ — укажите вид образовательного учреждения в соответствии с уставными документами.
Номер лицензии.
Регистрационный номер лицензии.
Дата выдачи лицензии.
Дата окончания действия лицензии.
Номер свидетельства об аккредитации.
Регистрационный номер свидетельства об аккредитации.
Дата выдачи свидетельства об аккредитации.
Дата окончания действия свидетельства об аккредитации.
Должность руководителя ОУ.
ФИО руководителя ОУ.
ФИО ответственного за ЕГЭ — указывайте ФИО полностью.
Количество классов и обучающихся в этих классах.
3. Исправив данные на странице основных сведений переключитесь на страницу Адреса и реквизиты.

Адреса и реквизиты
На странице адресов и реквизитов указываются следующие данные:
ИНН — ИНН ОУ.
КПП — КПП ОУ.
Расчетный счет — расчетный счет ОУ в банке.
Корреспондирующий счет — корр. счет ОУ в банке.
Название банка — наименование банка, в котором открыт счет ОУ.
Город банка — город, в котором располагается банк.
БИК банка — БИК банка, в котором открыт счет ОУ.
Административно-территориальная единица — АТЕ, на территории которой расположено ОУ. Поле не доступно для редактирования.
Тип населенного пункта — типа населенного пункта, на территории которого располагается ОУ.
Юридический адрес — укажите юридический адрес, согласно уставным документам.
Фактический адрес — укажите фактический адрес, если он отличается от юридического.
Телефоны — телефоны указываются через запятую, каждый телефон записывается в формате (<код>) <номер телефона>. Пробелы и тире в коде и номере телефона не ставятся.
Факсы — номера указываются через запятую, каждый номер записывается в формате (<код>) <номер факса>. Пробелы и тире в коде и номере факса не ставятся.
Адреса электронной почты — можно указать несколько адресов через точку с запятой.
WWW-сайт — адрес WWW-сервера образовательного учреждения.
4. Закончив исправление адресной информации перейдите к странице Компьютеры и Internet.

Комьютеры и Internet
На этой странице указываются данные по наличию в образовательном учреждении компьютеров и компьютерных классов, а так же способы подключения к сети Internet.
5. Заполнив все поля формы актуальными данными нажмите кнопку Сохранить. Все сведения будут записаны в базу данных.


Справочник учителей

Справочник учителей предназначен для редактирования данных по учителям ОУ.

Добавлять новых учителей, изменять данные учителей, удалять данные учителей следует в ОУ.

Открыть справочник можно выбрав пункт меню Модули—Справочник ОУ. В файлах экспорта ARE_XXXXXX.EXP содержатся данные по всем учителям района. В файлах SCH_XXXXXX.EXP содержатся данные только по учителям ОУ, для которого предназначен файл. На рисунке «Справочник учителей» показан справочник открытый в программе зарегистрированной на АТЕ. В программе, зарегистрированной на ОУ в дереве ОУ будет отображаться только одно образовательное учреждение, если дополнительно не загружались файлы других ОУ.

Справочник учителей

В окне можно изменять ширину колонок списков. Для этого нужно навести курсор мыши на границу колонок в заголовке окна, нажать левую клавишу мыши и, перемещая указатель мыши, изменить ширину колонки.

Изменение ширины колонок в списке учителей

Изменение ширины колонок в данных по учителю

Изменение ширины колонок в дополнительных сведениях по учителю

Аналогичным образом можно изменять ширину дерева ОУ и списка учителей

Изменение ширины дерева ОУ

Изменение ширины списка учителей

Вы можете изменять высоту списка данных по учителю. Для этого нужно навести курсор мыши на нижнюю границу списка, нажать левую клавишу мыши, и перемещая указатель вверх или вниз, изменить высоту списка.

Изменение высоты списка атрибутов

Некоторые данные по учителям представляют собой списки значений. Такие данные размещены в сворачивающихся панелях. Для просмотра этих данных нужно развернуть панель. Для этого наведите курсор мыши на кнопку [image] в заголовке панели и нажмите левую клавишу мыши.

Раскрытие панели «Преподаваемые предметы»

Для сворачивания панели наведите курсор мыши на кнопку [image] в заголовке панели и нажмите левую клавишу мыши.

Сворачивание панели «Преподаваемые предметы»
Пункт меню Вид или кнопка [image] на панели инструментов позволяют скртыть/отобразить дерево ОУ.


Добавить нового учителя

Для добавления записи на нового учителя нужно выполнить следующие действия:

1. В дереве ОУ выбрать образовательное учреждение, в которое будет добавлен новый учитель.

Выбор ОУ, в которое будет добавлен учитель
2. Выбрать пункт меню Данные—Добавить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+N. Будет открыто окно редактирования данных учителя.

Окно редактирования данных учителя. Страница «Работа»

В форме редактирования данных указываются следующие сведения по учителю:
Фамилия — фамилия учителя. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если фамилия двойная и записана через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если фамилия состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Имя — имя учителя. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если имя состоит из двух слов записанных через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если имя состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Отчество — отчество учителя. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если отчество состоит из двух слов записанных через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если отчество состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Пол.
Дата рождения.
Документ — вид документа удостоверяющего личность.
Серия документа — поле не должно содержать символов пробела, для каждого вида документа установлено ограничение на количество символов, вводимых в это поле:
- 4 арабские цифры для «Паспорта гражданина РФ»,
- 2 арабские цифры для «Временного удовтоверения»,
- 2 арабские цифры для «Вида на жительство»,
- 2 арабские цифры для «Заграниченого паспорта гражданина РФ»,
- для оставшихся видов документов в поле могут содержаться буквы кириллицы, латиницы и арабские цифры.
Номер документа — поле не должно содержать символов пробела, для каждого вида документа установлено ограничение на количество символов, вводимых в это поле:
- 6 арабских цифр для «Паспорта гражданина РФ»,
- 6 арабских цифр для «Временного удовтоверения»,
- 7 арабских цифр для «Вида на жительство»,
- 7 арабских цифр для «Заграниченого паспорта гражданина РФ»,
- для оставшихся видов документов в поле может быть записано не более 10 арабских цифр.
3. Заполнив основные сведения учителя перейдите к заполнению данных на странице «Работа»

Окно редактирования данных учителя. Страница «Работа»
На странице Работа вносятся следующие данные:
Труд. стаж — общий трудовой стаж (количество лет).
Пед. стаж — педагогический стаж (количество лет).
Стаж в ОУ— количество лет работы учителя в ОУ.
Тема самообразования — тематика научной деятельности учителя.
Данные о занимаемых должностях — внесите информацию по всем должностям, которые занимает учитель в ОУ. Для ввода новой записи, выделите последнюю строку в списке и нажмите на клавиатуре клавишу управления курсором Стрелка вниз или нажмите клавишу Insert. Для удаления записи нажмите сочетание клавиш Ctrl+Delete.
Данные о преподаваемых предметах — внесите сведения о всех предметах, которые преподает учитель. Данная информация используется для формирования отчетов и создания списка работников ППЭ. Для ввода новой записи, выделите последнюю строку в списке и нажмите на клавиатуре клавишу управления курсором Стрелка вниз или нажмите клавишу Insert. Для удаления записи нажмите сочетание клавиш Ctrl+Delete.
4. Заполнив данные на странице Работа переключитесь на страницу Образование / повышение квалификации.

Образование и повышение квалификации
На этой странице вводятся следующие данные:
Образование — укажите каждое полученное учителем образование, учебное заведение, год окончания и квалификацию по диплому. Для ввода новой записи, выделите последнюю строку в списке и нажмите на клавиатуре клавишу управления курсором Стрелка вниз или нажмите клавишу Insert. Для удаления записи нажмите сочетание клавиш Ctrl+Delete.
Ученая степень — укажите ученую степень учителя.
Ученое звание — укажите ученое звание учителя.
Научная специальность — укажите научную специальность учителя.
Повышение квалификации — укажите по крайней мере последние курсы повышения квалификации, пройденные учителем. Для ввода новой записи, выделите последнюю строку в списке и нажмите на клавиатуре клавишу управления курсором Стрелка вниз или нажмите клавишу Insert. Для удаления записи нажмите сочетание клавиш Ctrl+Delete.
5. Затем переключитесь на страницу Роль учителя в ППЭ.

Роль учителя в ППЭ
На этой странице пометьте все роли, которые учитель может (будет) исполнять в ППЭ. Данный список необходим для формирования списка работников ППЭ и допуска учителя для работы в ППЭ.
6. Последняя страница данных учителя называется Особые отметки.

Особые отметки
На данной странице можно ввести какие-то заметки относящиеся к учителю. Для ввода новой записи, выделите последнюю строку в списке и нажмите на клавиатуре клавишу управления курсором Стрелка вниз или нажмите клавишу Insert. Для удаления записи нажмите сочетание клавиш Ctrl+Delete.
7. Заполнив все поля формы актуальными данными нажмите кнопку Сохранить. Все сведения будут записаны в базу данных.


Изменить данные учителя

Для изменения данных учителя выполните следующие действия:

1. Выберите нужную запись в списке учителей.

Выбор учителя в списке
2. Выбрать пункт меню Данные—Изменить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+E. Будет открыто окно редактирования данных учителя.
3. Измените данные учителя и нажмите кнопку Сохранить для записи изменений в базу данных. Описание формы редактирования данных учителя приведено в разделе Добавить нового учителя.


Удалить данные учителя

Для удаления данных учителя из БД выполните следующие действия:

1. Выберите нужную запись в списке учителей.

Выбор учителя в списке
2. Выбрать пункт меню Данные—Удалить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+D. Будет выведено окно запроса на удаление.

Запрос на удаление записи
3. Нажмите кнопку Да для подтверждения удаления записи или Нет, чтобы отказаться от удаления записи.


Справочники участников

Работа со справочниками участников ЕГЭ и ГИА9 построена по одному и тому же алгоритму, поэтому операции добавления, изменения, удаления данных участников, назначение условий обучения и выставление оценок по предмету будет рассмотрено на примере участников ЕГЭ. Для справочника ГИА9 эти действия выполняются аналогично.

Рекомендуется придерживаться следующей последовательности действий при работе со справочниками участников:

1. Зарегистрировать всех участников, указав при этом какие предметы они выбрали для сдачи. При выборе предмета обязательно указывается дата сдачи.
2. Для выпускников текущего года и для учащихся 9-х классов проставить последние годовые/полугодовые оценки по предмету (это экспертная оценка знаний учащегося по предмету выставляемая учителем). Для выставления оценок рекомендуется использовать журнал оценок.
3. Для выпускников текущего года и для учащихся 9-х классов указать условия обучения по предмету. Для этого используйте форму редактирования условий обучения.
4. После окончания формирования списка участников данные можно выгрузить в файл для передачи в вышестоящую организацию.


Справочник участников ЕГЭ

Справочник участников ЕГЭ предназначен для формирования списка выпускников текущего года и выпускников прошлых лет, которые будут принимать участие в едином государственном экзамене.

Добавлять, изменять, удалять выпускников текущего года следует в образовательном учреждении, в котором обучается учащийся. Для выпускников текущего года указываются условия обучения и оценки по изучаемым предметам.

Выпускников прошлых лет следует приписывать к виртуальному образовательному учреждению вашего района. Для каждого района в базу данных добавлено одно виртуальное образовательное учреждение, название которого задается по шаблону «ВПЛ-<Название района>». Условия обучения по выпускникам прошлых лет не заполняются.

Открыть справочник можно выбрав пункт меню Модули—Справочник участников ЕГЭ. В файлах экспорта ARE_XXXXXX.EXP содержатся данные по всем участникам района. В файлах SCH_XXXXXX.EXP содержатся данные только по выпускникам ОУ, для которого предназначен файл. На рисунке «Справочник участников ЕГЭ» показан справочник открытый в программе зарегистрированной на АТЕ. В программе, зарегистрированной на ОУ в дереве ОУ будет отображаться только одно образовательное учреждение, если дополнительно не загружались файлы других ОУ.

Справочник участников ЕГЭ

В окне можно изменять ширину колонок списков. Для этого нужно навести курсор мыши на границу колонок в заголовке окна, нажать левую клавишу мыши и, перемещая указатель мыши, изменить ширину колонки.

Изменение ширины колонок в списке участников

Изменение ширины колонок в данных по участнику

Изменение ширины колонок в списке сдаваемых/изучаемых предметов

Изменение ширины колонок в списке учебников, используемых в обучении по предмету

Аналогичным образом можно изменять ширину дерева ОУ и списка участников

Изменение ширины дерева ОУ

Изменение ширины списка участников

Вы можете изменять высоту списка данных по участнику, высоту списка сдаваемых/изучаемых предметов и высоту списка учебников. Для этого нужно навести курсор мыши на нижнюю границу списка, нажать левую клавишу мыши, и перемещая указатель вверх или вниз, изменить высоту списка.

Изменение высоты списка атрибутов

Изменение высоты списка предметов

Изменение высоты списка учебников

Пункт меню Вид или кнопка [image] на панели инструментов позволяют скртыть/отобразить дерево ОУ.


Справочник участников ГИА9

Справочник участников ГИА9 предназначен для формирования списка учащихся 9-х классов, которые будут принимать участие в государственной итоговой аттестации.

Добавлять, изменять, удалять учащихся 9-х классов следует в образовательном учреждении, в котором обучается учащийся. Для учеников 9-х классов указываются условия обучения и оценки по изучаемым предметам.

Открыть справочник можно выбрав пункт меню Модули—Справочник участников ГИА9. В файлах экспорта ARE_XXXXXX.EXP содержатся данные по всем учащимся района. В файлах SCH_XXXXXX.EXP содержатся данные только по учащимся ОУ, для которого предназначен файл. На рисунке «Справочник участников ГИА9» показан справочник открытый в программе зарегистрированной на АТЕ. В программе, зарегистрированной на ОУ в дереве ОУ будет отображаться только одно образовательное учреждение, если дополнительно не загружались файлы других ОУ.

Справочник участников ГИА9

Возможности изменения внешнего вида элементов окна описаны в разделе «Справочник участников ЕГЭ».Работа с данными описана в следующих разделах.


Добавить нового участника

Рекомендуется использовать возможность автоматического заполнения полей формы значениями по умолчанию для новой записи. Это позволит ускорить процесс регистрации участников.

Для добавления нового участника в базу данных выполните следующие действия:

1. Откройте нужный вам справочник участников (справочник участников ЕГЭ или справочник участников ГИА9)
2. В дереве ОУ выберите образовательное учреждение, в которое будет добавлен новый участник.

Выбор ОУ, в которое будет добавлен участник
3. Выбрать пункт меню Данные—Добавить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+N. Будет открыто окно редактирования данных участника.

Окно редактирования данных участника

В форме редактирования данных указываются следующие сведения по участнику:
Фамилия — фамилия учителя. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если фамилия двойная и записана через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если фамилия состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Имя — имя учителя. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если имя состоит из двух слов записанных через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если имя состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Отчество — отчество учителя. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если отчество состоит из двух слов записанных через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если отчество состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Дата рождения.
Пол.
Документ — вид документа удостоверяющего личность.
Серия документа — поле не должно содержать символов пробела, для каждого вида документа установлено ограничение на количество символов, вводимых в это поле:
- 4 арабские цифры для «Паспорта гражданина РФ»,
- 2 арабские цифры для «Временного удовтоверения»,
- 2 арабские цифры для «Вида на жительство»,
- 2 арабские цифры для «Заграниченого паспорта гражданина РФ»,
- для оставшихся видов документов в поле могут содержаться буквы кириллицы, латиницы и арабские цифры.
Номер документа — поле не должно содержать символов пробела, для каждого вида документа установлено ограничение на количество символов, вводимых в это поле:
- 6 арабских цифр для «Паспорта гражданина РФ»,
- 6 арабских цифр для «Временного удовтоверения»,
- 7 арабских цифр для «Вида на жительство»,
- 7 арабских цифр для «Заграниченого паспорта гражданина РФ»,
- для оставшихся видов документов в поле может быть записано не более 10 арабских цифр.
Родной язык.
Гражданство.
Признак специализированной рассадки — установите этот флаг, если для учащегося не будет использоваться автоматизированная рассадка на экзамен.
Категория участника.
Форма обучения.
Класс.
Претендент на медаль — укажите претендует ли выпускник на получение медали. Для учащихся 9-х классов и выпускников прошлых лет в данном поле указывается Нет.
Год окончания ОУ — для участников ЕГЭ указывается код окончания образовательного учреждения, тип которого указан в поле Категория участника, для учащихся 9-х классов указывается год окончания 9-го класса.
Регион окончания ОУ — поле заполняется для учащихся, окончивших ОУ не в Алтайском крае.
Проходит ГИА в текущем году — установите этот флаг, если учащийся участвует в государственной итоговой аттестации в текущем году. Для учащихся 9-х классов и выпускников этого года это поле всегда должно быть помечено.
Действующие результаты ГИА — для выпускников текущего года и для учащихся 9-х классов в этом поле будет стоять Нет, для выпускников прошлых лет необходимо указать подходящий вариант.
Изучаемые предметы — для выпускников текущего года и для учащихся 9-х классов пометьте те предметы, которые изучаются учащимся, затем пометьте все предметы, который учащийся будет сдавать в форме ЕГЭ. При выборе предмета для сдачи выберите дату сдачи предмета из расписания. Для выбора даты сдачи нужно раскрыть список дней экзамена.

Выбор даты экзамена

Предмет автоматически помечается как «изучаемый предмет», если учащемуся поставить оценку по предмету. Для быстрого ввода оценок по предметам рекомендуется использовать журнал оценок. Таким образом, если вы будете выставлять оценки всем учащимся по всем изучаемым предметам в журнале оценок, то в форме редактирования данных участника проставлять пометки и оценки по изучаемым предметам не обязательно.

4. Заполнив все поля формы актуальными данными нажмите кнопку Сохранить. Все сведения будут записаны в базу данных.


Значение полей по умолчанию

Для большинства учащихся школы значения некоторых полей формы редактирования будут совпадать. Программа предоставляет возможность настроить значения по умолчанию, которые будут подставляться в поля формы редактирования для каждой новой записи.

Чтобы настроить значения полей по умолчанию выполните следующие действия:

1. Откройте нужный вам справочник участников (справочник участников ЕГЭ или справочник участников ГИА9)
2. В дереве ОУ выберите какое-нибудь образовательное учреждение.

Выбор ОУ, в которое будет добавлен участник
3. Выбрать пункт меню Данные—Добавить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+N. Будет открыто окно редактирования данных участника.

Окно редактирования данных участника
4. Установите все значения, которые должны автоматически подставляться в форму для каждой новой записи (см. пример на рисунке ниже).

Пример значений по умолчанию
5. Нажмите кнопку [image] в нижней левой части окна для того, чтобы запомнить введенные значения. После этого при добавлении нового участника указанные значения будут автоматически подставляться в форму.

Для того чтобы просмотреть список значений по умолчанию нажмите кнопку [image] в левой нижней части окна. Если эта кнопка недоступна, значит значения по умолчанию не установлены.

Для того чтобы очистить список значений по умолчанию нажмите кнопку [image] в левой нижней части окна. Если эта кнопка недоступна, значит значения по умолчанию не установлены.


Изменить данные участника

Для изменения данных участника выполните следующие действия:

1. Откройте нужный вам справочник участников (справочник участников ЕГЭ или справочник участников ГИА9)
2. Выберите нужную запись в списке участников.

Выбор участника в списке
3. Выбрать пункт меню Данные—Изменить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+E. Будет открыто окно редактирования данных участника.
4. Измените данные участника и нажмите кнопку Сохранить для записи изменений в базу данных. Описание формы редактирования данных участника приведено в разделе Добавить нового участника.


Удалить данные участника

Для удаления данных участника из БД выполните следующие действия:

1. Откройте нужный вам справочник участников (справочник участников ЕГЭ или справочник участников ГИА9)
2. Выберите нужную запись в списке участников.
3.
Выбор участника в списке
4. Выбрать пункт меню Данные—Удалить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+D. Будет выведено окно запроса на удаление.

Запрос на удаление записи
5. Нажмите кнопку Да для подтверждения удаления записи или Нет, чтобы отказаться от удаления записи.


Журнал оценок

Журнал оценок предназначен для ввода учащимся оценок по предмету. В качестве вводимой оценки используется экспертная оценка знаний учащегося по предмету, выставленная учителем.

Чтобы открыть журнал оценок выполните следующие действия:

1. Откройте нужный вам справочник участников (справочник участников ЕГЭ или справочник участников ГИА9)
2. В дереве ОУ выберите образовательное учреждение, учащимся которого будут выставляться оценки.

Выбор ОУ
3. Выбрать пункт меню Данные—Журнал оценок.

Журнал оценок

В окне журнала оценок проставьте каждому учащемуся оценки по всем изучаемым предметами из списка.
4. Нажмите кнопку Сохранить для записи изменений в базу данных.


Условия обучения

Условия обучения заполняются на выпускников текущего года и на учащихся 9-х классов. Условия обучения можно заполнить только в том случае, если у учеников указаны изучаемые предметы. Самый быстрый способ указать каждому ученику все изучаемые предметы это проставить оценки по этим предметам. Для этого следует воспользоваться журналом оценок.

Если у всех учеников проставлены изучаемые предметы, то можно приступать к заполнению условий обучения.

1. Откройте нужный вам справочник участников (справочник участников ЕГЭ или справочник участников ГИА9)
2. В дереве ОУ выберите образовательное учреждение, учащимся которого будут заполняться условия обучения.

Выбор ОУ
3. Выбрать пункт меню Данные—Условия обучения.

Условия обучения по предметам
В дереве «Предметы и подгруппы» отображаются только те предметы, которые помечены хотя бы у одного ученика как изучаемый предмет.
В списке учащихся присутствуют те ученики, у которых предмет, выбранный в дереве, помечен как изучаемый.

Назначение условий обучения сводится к двум действиям:

1. Деление учащихся на подгруппы обучения.
2. Назначение условий обучения подгруппе или классу.


Подгруппы обучения

Если изучения предмета в классе ведется по подгруппам, и условия обучения в этих подгруппах разные, то перед назначением условий обучения целесообразно разделить класс на подгруппы. Для этого:

1. В окне условий обучения в дереве предметов и подгрупп выберите сначала предмет а затем класс, который нужно разделить на подгруппы.

Условия обучения по предметам
2. Нажмите кнопку [image] на панели инструментов или сочетание клавиш Ctrl+G. Откроется мастер «Подруппы обучения».

Мастер «Подгруппы обучения»
3. Укажите количество подгрупп по предмету.
4. Выберите текущую подгруппу №1.
5. Поставьте метки всем учащимся, которые должны входить в эту подгруппу.

Выбор учащихся первой подгруппы
6. Выбреите следующую подгруппу и выполните п. 5.
В каждой подгруппе отображаются те учащиеся, которые еще относятся к подгруппе или еще не распределены.

Выбор учащихся второй подгруппы
7. После того, как будут распределены все учащиеся нажмите кнопку Сохранить.

Для того чтобы расформировать подгруппу нужно:

1. Выбрать подгруппу в дереве «Подгруппы и подгруппы»

Выбор подгруппы
2. Нажмите кнопку [image] на панели инструментов или сочетание клавиш Ctrl+D. Выбранная группа будет расформирована.

Группа №1 расформирована


Назначение условий обучения

После того как учащиеся разделены на подгруппы можно назначать условия обучения. Для этого:

1. В окне условий обучения в дереве предметов и подгрупп выберите сначала предмет а затем класс (а при необходимости и подгруппу). В списке учащихся будут отображены фамилии учащихся условия обучения для которых можно будет назначить..

Условия обучения по предметам
2. Нажмите кнопку [image] на панели инструментов или нажмите сочетание клавиш Ctrl+E, будет открыто окно редактирования условий обучения.

Редактирование условий обучения

Заполните все поля формы:
Базисный учебный план — выбирается из предложенного справочника.
Профиль обучения — выбирается из предложенного справочника.
Язык преподавания предмета — выбирается из предложенного справочника.
Уровень изучения предмета — выбирается из предложенного справочника.
Среднее количество часов в неделю — среднее количество часов по предмету в неделю в последний год изучения предмета, можно вводить дробное число.
Учитель — учитель по предмету выбирается из справочника учителей ОУ, установка флага Показывать только учителей предметников, отбирает в список учителей только тех учителей, у которых в преподаваемых предметах выбран текущий предмет и указана соответствующая ступень образования.
Число месяцев работы — указывается целое число месяцев работы учителя с учмщимся.
Учебникики, по которым изучается предмет — пометьте все учебники в списке, которые используется для преподавания предмета.
3. После того как будут заполнены все поля формы нажмите кнопку Сохранить, для того чтобы назначить условия обучения только выбранному учащемуся (на рисунке «Условия обучения по предмету» выбран ученик Гребенюк Татьяна Александровна). Или нажмите кнопку Сохранить для всех, чтобы назначить условия обучения всем учащимся в списке (на рисунке «Условия обучения по предмету» это ученики 11 класса).


Справочник ППЭ

Справочник ППЭ предназначен для регистрации пунктов проведения экзаменов, составления списка аудиторий и посадочных мест предназначенных для проведения экзаменов.

Регистрировать ППЭ, изменять данные ППЭ, удалять ППЭ следует в МОУО.

Открыть справочник можно выбрав пункт меню Модули—Справочник ППЭ. В файлах экспорта ARE_XXXXXX.EXP содержатся данные по всем ППЭ района.

Справочник ППЭ

Все посадочные места в аудиториях отображаются в виде ячеек таблицы. Каждая ячейка таблицы содержит номер посадочного места. Буква обозначает ряд, а число — номер места в ряду. Если в ячейка пуста, значит это место помечено как отсутствующее и не будет использоваться программой для распределения учащихся.

В окне можно изменять ширину колонок списков. Для этого нужно навести курсор мыши на границу колонок в заголовке окна, нажать левую клавишу мыши и, перемещая указатель мыши, изменить ширину колонки.

Изменение ширины колонок в списке ППЭ

Изменение ширины колонок в данных по ППЭ

Изменение ширины колонок в списке аудиторий

Аналогичным образом можно изменять ширину дерева АТЕ, списка ППЭ и списка аудиторий

Изменение ширины дерева ППЭ

Изменение ширины списка ППЭ

Изменение ширины списка аудиторий

Вы можете изменять высоту списка данных ППЭ. Для этого нужно навести курсор мыши на нижнюю границу списка, нажать левую клавишу мыши, и перемещая указатель вверх или вниз, изменить высоту списка.

Изменение высоты списка атрибутов

Пункт меню Вид или кнопка [image] на панели инструментов позволяют скртыть/отобразить дерево ОУ.


Регистрация нового ППЭ

Для регистрации нового ППЭ выполните следующие действия:

1. В дереве АТЕ выберите административную единицу, в в которой нужно зарегистрировать новый пункт.

Выбор АТЕ для регистрации нового пункта проведения экзамена
2. Выбрать пункт меню Данные—Добавить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+N. Будет открыто окно редактирования данных ППЭ.

Окно редактирования данных ППЭ

В форме редактирования данных указываются следующие сведения по ППЭ:
Код ППЭ — задается по следующим правилам:
- Код состоит из четырех цифр.
- Первые (старшие разряды) две цифры — это код АТЕ записанный с ведущими нулями. Для Алейского района это будет «01», для Завьяловского района «11».
- Последние две цифры — это порядковый номер ППЭ в районе, записанный с ведущим нулем.
Итак, чтобы правильно составить коды ППЭ в вашем районе, нужно сделать следующее:
1. Выписать названия всех ППЭ вашего района.
2. Пронумеровать их числами от 1 до 99.
3. Код вашего района умножить на 100 и прибавить полученное число к каждому номеру ППЭ, присвоенному на шаге 2.
4. Полученные числа будут кодами ваших ППЭ. В программе коды ППЭ отображаются с ведущими нулями.
Название ППЭ — указывается в соответствии с приказом, утверждающим создание пункта проведения. Это название используется в программе для формирования всех отчетов по ППЭ.
Базовое ОУ — образовательное учреждение, на базе которого создается ППЭ. Поле не обязательное для заполнения. Если ППЭ организуется на базе школы, то достаточно выбрать из списка базовое ОУ и все поля формы будут заполнены данными базового ОУ (кроме списка аудиторий).
Адрес — фактический адрес ППЭ. При выборе базового ОУ адрес может быть заменен на фактический адрес ОУ по желанию пользователя.
Телефоны — телефоны ППЭ. При выборе базового ОУ телефоны могут быть заменены на телефоны ОУ по желанию пользователя.
Электронный адрес — адрес электронной почты ППЭ. При выборе базового ОУ адрес электронной почты может быть заменен на адрес электронной почты ОУ по желанию пользователя.
3. Заполните данные по аудиториям и посадочным местам (подробнее смотрите раздел «Работа со списком аудиторий и посадочными местами».
4. Заполнив все поля формы актуальными данными нажмите кнопку Сохранить. Все сведения будут записаны в базу данных.


Изменение данных ППЭ

Для изменения данных ППЭ, в том числе для изменения списка аудиторий или посадочных мест, выполните следующие действия:

1. Выберите нужную запись в списке ППЭ.

Выбор ППЭ в списке
2. Выбрать пункт меню Данные—Изменить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+E. Будет открыто окно редактирования данных учителя.
3. Измените данные ППЭ (как добавить или удалить аудиторию см. «Работа со списком аудиторий и посадочными местами») и нажмите кнопку Сохранить для записи изменений в базу данных. Описание формы редактирования данных ППЭ приведено в разделе «Регистрация нового ППЭ».


Удалить ППЭ

Если в базе данных имеются данные распределения учащихся в аудитории ППЭ, то при попытке удаления данного ППЭ будет выведено сообщение об ошибке, и удаление не будет выполнено.

Для удаления данных ППЭ из БД необходимо выполнить следующие действия:

1. Выбрать нужную запись в списке ППЭ.

Выбор учителя в списке
2. Выбрать пункт меню Данные—Удалить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+D. Будет выведено окно запроса на удаление.

Запрос на удаление записи
3. Нажмите кнопку Да для подтверждения удаления записи или Нет, чтобы отказаться от удаления записи.


Работа со списком аудиторий и посадочными местами

Список аудиторий, используемых для распределения учащихся на экзамены должен быть заполнен на этапе регистрации пунктов проведения экзаменов. Крайне не рекомендуется изменять список аудиторий на этапе проведения экзаменов. На основе составленного списка аудиторий вычисляется вместимость ППЭ.

Редактирование списка аудиторий производится в форме редактирования данных ППЭ. Список аудиторий может быть заполнен как при регистрации нового ППЭ, так и при редактировании данных уже зарегестрированного пункта.

Для составления списка аудиторий и формирования списка посадочных мест в программе реализованы следующие возможности:

· добавление аудитории;
· задание номера и размеров аудитории;
· пометка отсутствующих (неиспользуемых) мест;
· удаление аудитории из списка;
· отмена удаления аудитории.


Добавить аудиторию

Для того чтобы добавить новую аудиторию в список аудиторий ППЭ нажмите кнопку со знаком «+», расположенную слева над списком аудиторий:

Добавить аудиторию

Если перед этим вы удаляли аудитории из списка, то будет открыт список удаленных аудиторий. В конце списка имеется пункт «Новая», позволяющий добавить новую, а не восстановить удаленную аудиторию.

Добавить новую аудиторию

Если аудитории не удалялись, то новая аудитория будет добавлена сразу. Этой аудитории будет присвоен некоторый номер с буквой «н» в конце.

Данные аудиторий располагаются на вкладках, названия которых совпадают с номерами аудиторий.

Переход к данным аудитории при выборе вкладки


Изменить номер или размер аудитории

Для изменения номера или размера аудитории выполните следующие действия:

1. Активируйте вкладку аудитории

Переход к данным аудитории при выборе вкладки
2. Установите курсор в поле номера аудитории и впишите актуальные данные.

Изменение номера аудитории
3. Установите курсор в поле количества рядов и укажите число рядов в аудитории. Если задано число парт в ряду, то сделанные изменения сразу же будут отражены в списке «Места в аудитории»

Изменение количества рядов
4. Установите курсор в поле количества парт в ряду и укажите максимальное количество парт по рядах аудитории. Если задано число рядов, то сделанные изменения сразу же будут отражены в списке «Места в аудитории»

Изменение количества мест в ряду


Пометить отсутствующие/неиспользуемые места

Количество мест в аудитории задается числом рядов и числом мест в ряду. Т.е. всегда считается что посадочные места в аудитории расположены в виде прямоугольной таблицы. На практике некоторые места в аудитории могут отсутствовать. Такие места следует пометить как неиспользуемые и тем самым исключить из использования в программе.

Чтобы пометить какое-то место аудитории как отсутствующее нужно навести курсор мыши на номер этого места и дважды нажать левую клавишу. Соответствующая ячейка списка мест будет перечеркнута красным крестом.

Пометить место как неиспользуемое

Если навести курсор мыши на номер места, помеченного как неиспользуемое и дважды нажать левую клавишу мыши, то пометка будет снята и данное посадочное место будет использоваться программой в процессе распределения учащихся на экзамен.


Удалить аудиторию

Для того чтобы удалить аудиторию из списка нужно выбрать вкладку аудитории инажать кнопку со знаком «-», расположенную слева над списком аудиторий.

Удалить аудиторию


Отменить удаление аудитории

Если вы ошибочно удалили из списка нужную аудиторию, то ее можно восстановить. Для этого нажмите кнопку со знаком «+», расположенную слева над списком аудиторий и в открывшемся списке выберите номер восстанавливаемой аудитории.

Отменить удаление аудитории

Заметим, операция восстановления удаленной аудитории доступна до тех пор, пока активна форма редактирования данных ППЭ. Как только будет нажата кнопка Сохранить все изменения будут внесены в БД. При повторном открытии формы редактирования список удаленных аудиторий будет пустым.


Приписка ОУ к ППЭ

Данный модуль предназначен для приписки образовательных учреждений к пунктам проведения экзаменов на отдельные экзамены.

Основная форма модуля состоит из двух частей: в левой части отображается дерево ППЭ в правой части отображается список этапов и приписка ОУ к ППЭ по выбранному этапу.

Приписка ОУ к ППЭ

При выборе АТЕ или конкретного ППЭ в правой части формы отображается список образовательных учреждений района.

Этапы проведения государственной итоговой аттестации отображаются в виде отдельных вкладок в правой части окна. При выборе конкретной вкладки в заголовках столбцов таблицы отображаются даты экзаменов по выбранному этапу ГИА. А в ячейках таблицы отображаются названия пунктов проведения экзаменов, к которым приписаны ОУ на экзамены. Для просмотра всех дней экзаменов воспользуйтесь горизонтальной полосой прокрутки внизу таблицы.

Если ОУ не приписано на какой-то день ни к одному ППЭ, а в ОУ зарегистрированы учащиеся, выбравшие эту дату для сдачи экзамена, то ячейка дня экзамена будет отображена красным цветом. Кроме того, если есть хоть один день этапа, на который нет приписки ОУ к ППЭ, но есть учащиеся, сдающие в этот день экзамен, то ячейка с названием ОУ так же будет подсвечена красным цветом. Выделение красным цветом работает только в том случае, если в базу данных внесены сведения участникам и сведения по выбору сдаваемых предметов. Поэтому при приписке ОУ к ППЭ не следует ориентироваться только на наличие «красных» ячеек, т.к. выбор экзаменов может изменять в течении довольно длительного времени.

Если навести курсор мыши на ячейку таблицы, то будет выведена подсказка с полным текстом ячейки.

Подсказка по тексту ячейки

Если в списке ППЭ, расположенном в правой части формы, выбран конкретный пункт проведения, то ячейки таблицы, в которых указана приписка ОУ к этому пункте, будут подсвечены зеленым цветом.

Алгоритм приписки ОУ к ППЭ описан в разделе «Приписать ОУ к ППЭ на экзамены».


Приписать ОУ к ППЭ на экзамены

Для того чтобы приписать образовательные учреждения к пункту проведения экзамена выполните следующие действия:

1. Выберите в списке ППЭ пункт, к которому будут приписываться образовательные учреждения.
2. Выберите этап, по которому будет выполняться приписка.
3. Выберите пункт меню Данные—Изменить, или нажмите кнопку [image] на панели инструментов, или нажмите сочетание клавиш Ctrl+E. Будет открыто окно приписки ОУ к ППЭ. В заголовке окна отображается код и название пукнта проведения экзамена, к которому будет производиться приписка.

Окно приписки ОУ к ППЭ
4. Для того чтобы приписать одно ОУ на один экзамен нужно выбрать ячейку на пересечении строки с названием ОУ и столбца с датой экзамена и дважды нажать левую клавишу мыши. В ячейке должно отобразиться код и название ППЭ а фон ячейки заполнится зеленым цветом.
5. Для того чтобы приписать все ОУ к ППЭ на один экзамен нужно выделить какую-либо ячейку в стоблце с датой выбранного экзамена и нажать кнопку [image] в левом нижнем углу формы.
6. Для того чтобы приписать выбранные ОУ к ППЭ на один экзамен нужно удерживая клавишу Ctrl выделить ячейки на пересечении строк с названиями приписываемых ОУ и столбцов с датой экзамена. Затем нажать кнопку [image] в левом нижнем углу формы.

Выбор нескольких ОУ для приписки
7. Кнопка [image] позволяет приписать к ППЭ на выбранный экзамен те школы, которые еще не приписаны ни к одному из пунктов. Если выбрана только одна ячейка в столбце, то будут приписаны все неприписанные ОУ района, если выделено несколько ячеек, то будут обработаны только выбранные ОУ.
8. Кнопка [image] позволяет отписать ОУ от текущего ППЭ по выбранному экзамену. Если выбрана только одна ячейка в столбце, то от текущего ППЭ на выбранный экзамен будут отписаны все школы района. Если выбрано несколько ячеек в столбце, то будут обработаны только выбранные строки.
9. Кнопка [image] удаляет все приписки по выбранному дню. Если выбрана только одна ячейка в столбце ту будут удалены приписки на экзамен по всем школам. Если выбрано несколько ячеек, то будут удалены приписки только по выбранным строкам.
10. Кнопка [image] позволяет приписать выбранные ОУ к текущему ППЭ на все экзамены этапа. Выбор нескольких ОУ делается мышью при удерживании в нажатом положении клавиши Ctrl (свободный выбор) или Shift (выбор последовательного списка).
11. Кнопка [image] позволяет приписать выбранные ОУ к текущему ППЭ на те экзамены, по которым еще нет установленных приписок. Т.е. заполняются еще пустые ячейки.
12. Кнопка [image] позволяет отписать выбранные ОУ от текущего ППЭ по всем экзаменам. Если ОУ приписано к другому ППЭ, а не к текущему, то приписка удалена не будет.
13. Кнопка [image] удаляет все приписки по выбранным ОУ по всем экзаменам.


Справочник работников ППЭ

Справочник работников ППЭ предназначен для формирования списка людей, которые будут участвовать в организации экзаменов. Под термином "работник" понимается все кто допускается в ППЭ на время проведения экзамена, это:

1. Руководитель ППЭ.
2. Организатор в аудитории ППЭ.
3. Организатор вне аудитории ППЭ.
4. Ассистент.
5. Уполномоченный ГЭК.
6. Общественный наблюдатель.

Назначенные роли показывают в каком качестве работник может принимать участие в проведении экзамена. Во время формирования списка работников следует указать все возможные роли, которые работник будет выполнять во время проведения экзаменов. Так, например, один и тот же человек может на одном экзамене быть руководителем, на другом организатором, на третьем ассистентом, все эти роли нужно пометить для данного работника. Список ролей будет использоваться при распределении работников на конкретный экзамен.

Список работников ППЭ формируется в МОУО. Все работники на этапе сбора данных приписываются к АТЕ, а не к конкретному ППЭ. В дальнейшем полный список работников будет предаваться в ППЭ для распределения на экзамены.

Для управления списком работников ППЭ в программе реализованы следующие функции:

1. Сформировать список работников по списку учителей.
Данная функция позволяет заполнить список работников на основе данных по учителям. Для этого у учителей должны быть указаны роли, которые он может выполнять в ППЭ. (см. роли учителя в ППЭ).
2. Добавить нового работника.
3. Изменить данные работника.
4. Удалить данные работника.

Открыть справочник можно выбрав пункт меню Модули—Справочник работников ППЭ. В файлах экспорта ARE_XXXXXX.EXP и STA_XXXXXX.EXP содержатся данные по всем работникам ППЭ вашего района.

Справочник работников ППЭ

В окне можно изменять ширину колонок списков. Для этого нужно навести курсор мыши на границу колонок в заголовке окна, нажать левую клавишу мыши и, перемещая указатель мыши, изменить ширину колонки.

Изменение ширины колонок в списке работников

Изменение ширины колонок в данных по работнику

Изменение ширины колонок в списке предметов специализации

Изменение ширины колонок в списке ролей

Аналогичным образом можно изменять ширину дерева АТЕ и списка работников

Изменение ширины дерева АТЕ

Изменение ширины списка учителей

Вы можете изменять высоту списка данных по работнику. Для этого нужно навести курсор мыши на нижнюю границу списка, нажать левую клавишу мыши, и перемещая указатель вверх или вниз, изменить высоту списка.

Изменение высоты списка атрибутов

Изменение высоты списка предметов специализации

Изменение высоты списка ролей

Пункт меню Вид или кнопка [image] на панели инструментов позволяют скртыть/отобразить дерево АТЕ.


Сформировать список работников по списку учителей

Данная функция позволяет заполнить список работников на основе данных по учителям. Для этого у учителей должны быть указаны роли, которые он может выполнять в ППЭ. (см. роли учителя в ППЭ).

Чтобы заполнить список работников на основе данных по учителям выполните следующие действия:

1. Выберите пункт меню Данные—Сформировать список работников.
2. Перед началом формирования списка вам будет задан вопрос

Режим формирования списка работников ППЭ

Ответьте Да, если список нужно очистить и заполнить заново. При этом из списка будут удалены все работники, кроме тех, которые уже были распределены на экзамен.
Ответьте Нет, если список нужно добавить/исправить данными из справочника учителей. При этом, если данные какого-то работника заполнены на основе данных по учителю, то все данные работника будут заменены на данные по учителю.
3. По окончании работы функции на экране отобразится обновленный список работников.


Добавить нового работника

Для регистрации нового работника ППЭ выполните следующие действия:

1. В дереве АТЕ выберите административную единицу, в в которой нужно зарегистрировать работника.

Выбор АТЕ для регистрации нового работника ППЭ
2. Выбрать пункт меню Данные—Добавить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+N. Будет открыто окно редактирования данных работника ППЭ.

Окно редактирования данных работника ППЭ

В форме редактирования данных указываются следующие сведения по работнику ППЭ:
Код учителя — заполняется в том случае, если работником является учитель. Процедура выбора учителя в качестве работника ППЭ будет описана ниже.
Фамилия — фамилия работника. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если фамилия двойная и записана через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если фамилия состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Имя — имя работника. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если имя состоит из двух слов записанных через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если имя состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Отчество — отчество работника. Допустим ввод только русских букв, тире и пробела. Перед записью в базу регистр букв будет изменен по следующим правилам:
- первая буква будет приведена к верхнему регистру;
- если отчество состоит из двух слов записанных через дефис, то первые буквы обоих слов будут приведены к верхнему регистру;
- если отчество состоит из двух слов разделенных пробелом, то первая буква первого слова будет приведена к верхнему регистру, первая буква второго слова останется без изменений;
- остальные буквы будут приведены к нижнему регистру.
Дата рождения.
Пол.
Документ — вид документа удостоверяющего личность. Не обязательное для заполнения поле. Если вид документа не указывается, то серия и номер тоже не указываются.
Серия документа — поле не должно содержать символов пробела, для каждого вида документа установлено ограничение на количество символов, вводимых в это поле:
- 4 арабские цифры для «Паспорта гражданина РФ»,
- 2 арабские цифры для «Временного удовтоверения»,
- 2 арабские цифры для «Вида на жительство»,
- 2 арабские цифры для «Заграниченого паспорта гражданина РФ»,
- для оставшихся видов документов в поле могут содержаться буквы кириллицы, латиницы и арабские цифры.
Номер документа — поле не должно содержать символов пробела, для каждого вида документа установлено ограничение на количество символов, вводимых в это поле:
- 6 арабских цифр для «Паспорта гражданина РФ»,
- 6 арабских цифр для «Временного удовтоверения»,
- 7 арабских цифр для «Вида на жительство»,
- 7 арабских цифр для «Заграниченого паспорта гражданина РФ»,
- для оставшихся видов документов в поле может быть записано не более 10 арабских цифр.
Основное место работы — не обязательное для заполнения поле.
Должность по основному месту работы — не обязательное для заполнения поле.
3. Пометьте все предметы специализации. Предмет специализации означает, что работник не может участвовать в проведении экзамена по данному предмету.
4. Пометьте все роли, которые работник может выполнять. Список ролей необходим процедуры распределения работников на экзамен.
5. Если в работником ППЭ является учитель, данные по которому внесены в базу данных, то можно заполнить форму выбрав учителя из списка. Для этого нужно нажать кнопку в правой части поля Код учителя [image]. В открывшемся окне выберите учителя, который является работником ППЭ.

Выбор работника из списка учителей

Список можно сортировать по любому из столбцов. Для этого нужно навести курсор мыши на заголовок столбца и нажать левую клавишу мыши. Если при этом удерживать нажатой клавишу Ctrl, то можно задать сортировку списка по нескольким столбцам (интересно только зачем это надо в этом списке?).
Кроме того, в списке можно производить инкрементный поиск. Установите фокус на содержимое столбца ФИО (кликните мышкой в любую ячейку этого столбца). Переключите раскладку клавиатуры на русский язык. Начните вводить фамилию. Кстати, данный вид поиска работает и в других списках, как-то — список участников, список учителей, список ОУ и пр.
Выбрав нужного учителя нажмите кнопку Выбрать.
После закрытия формы выбора отредактируйте данные работника, если это необходимо.
6. Заполнив все поля формы актуальными данными нажмите кнопку Сохранить. Все сведения будут записаны в базу данных.


Изменить данные работника

Для изменения данных работника ППЭ выполните следующие действия:

1. Выберите нужную запись в списке работников.

Выбор работника в списке
2. Выбрать пункт меню Данные—Изменить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+E. Будет открыто окно редактирования данных работника.
3. Измените данные работника и нажмите кнопку Сохранить для записи изменений в базу данных. Описание формы редактирования данных работника приведено в разделе Добавить нового работника.


Удалить данные работника

Для удаления данных работника ППЭ из БД выполните следующие действия:

1. Выберите нужную запись в списке работников.
2.
Выбор работника в списке
3. Выбрать пункт меню Данные—Удалить, или нажать кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+D. Будет выведено окно запроса на удаление.

Запрос на удаление записи
4. Нажмите кнопку Да для подтверждения удаления записи или Нет, чтобы отказаться от удаления записи.


Распределение на экзамен

Модуль распределения на экзамены предназначен для записи участников и работников ППЭ на экзамен, распределения организаторов по аудиториям, распределения участников по посадочным местам, печати отчетных форм и списков. Под термином "работник" понимается все кто допускается в ППЭ на время проведения экзамена, это:

1. Руководитель ППЭ.
2. Организатор в аудитории ППЭ.
3. Организатор вне аудитории ППЭ.
4. Ассистент.
5. Уполномоченный ГЭК.
6. Общественный наблюдатель.

Список работников ППЭ формируется в МОУО. Все работники на этапе сбора данных приписываются к АТЕ, а не к конкретному ППЭ. Перед каждым экзаменом рекомендуется передавать список работников ППЭ из МОУО в пункты проведения экзаменов.

Распределение участников и работников на экзамен выполняется по следующей схеме:

1. Подготовка распределения (выполняется в МОУО).
2. Передача данных приписки в ППЭ.
3. Выполнение распределения (выполняется в ППЭ или МОУО).
4. Печать отчетных форм и списков.
5. Передача данных распределения в МОУО.

Открыть модуль распределения можно выбрав пункт меню Модули—Распределение на экзамен. На рисунке ниже представлено окно программы зарегистрированной на АТЕ. Если программа будет зарегистрирована на ППЭ, то в дереве ППЭ будет только один пункт проведения экзамена, на который зарегистрирована программа.

В зависимости от количества участников выбранных для распределения на экзамен будет рассчитано необходимое число посадочных мест. Требуемое число организаторов будет рассчитано на основе выбранных для проведения экзамена аудиторий. Если число выбранных аудиторий или организаторов будет меньше необходимого числа, то соответствующие итоговые строки в списках будут подсвечены красным цветом.

Распределение на экзамен

В окне можно изменять ширину колонок списков. Для этого нужно навести курсор мыши на границу колонок в заголовке окна, нажать левую клавишу мыши и, перемещая указатель мыши, изменить ширину колонки.

Изменение ширины колонок в списке участников

Изменение ширины колонок в списке работников ППЭ

Изменение ширины колонок в списке используемых аудиторий

Аналогичным образом можно изменять ширину дерева ППЭ и списков

Изменение ширины дерева ППЭ

Изменение ширины списков

Вы можете изменять высоту списков. Для этого нужно навести курсор мыши на нижнюю границу списка, нажать левую клавишу мыши, и перемещая указатель вверх или вниз, изменить высоту списка.

Изменение высоты списков участников и работников

Изменение высоты списков аудиторий и посадочных мест

Пункт меню Вид или кнопка [image] на панели инструментов позволяют скртыть/отобразить дерево ППЭ.


Подготовка распределения

Это наиболее трудоемкий этап распределения учащихся и организаторов на экзамен. Подготовка распределения должна выполняться в МОУО. Затем подготовленные данные передаются в ППЭ.

Подготовительный этап состоит из следующих шагов:

1. Выбор ППЭ и экзамена.
2. Запуск мастера подготовки экзамена.
3. Подготовка списка участников экзамена.
4. Подготовка списка аудиторий для экзамена.
5. Подготовка списка работников.

После того, как будут подготовлены все списки можно переходить к экспорту данных по распределению в ППЭ.


Выбор ППЭ и экзамена

На первом шаге подготовки к распределению необходимо выбрать ППЭ, в котором будет производиться распределение. Для этого в дереве ППЭ найдите узел с названием нужного пункта проведения экзамена и активируйте этот узел (см. рисунок «Выбор ППЭ»).

Выбор ППЭ

Затем из расписания нужно выбрать экзамен, по которому будет выполняться распределение. Для этого используйте поле в верхней части рабочей области:

Экзамен, по которому выполняется распределение

Для выбора экзамена используйте один списков дней экзаменов:

· сквозной список экзаменов,
· сгруппированный список экзаменов.

Сквозной список раскрывается при нажатии кнопки [image] в правой части поля:

Выбор экзамена из сквозного списка

Сгруппированный список раскрывается при нажатии кнопки [image] в правой части поля:

Выбор экзамена в сгруппированном списке

В этом списке расписание экзаменов сгруппировано по этапам. Экзамены, которые проводятся в один и тот же день, выделены общим цветом фона.

Для выбора экзамена используйте тот список, который вам более удобен (мы остановим свой выбор на экзамене «10.06.2011 - 08 География. ЕГЭ - основной этап (июнь). Основной день.»). После выбора экзамена переходите к работе с мастером подготовки списков.


Запуск мастера подготовки экзамена

После выбора ППЭ и экзамен переходим к формированию списков участников, используемых аудиторий и работников ППЭ. Списки формируются с использованием мастера подготовки экзамена. Чтобы запустить мастер выберите пункт меню Данные—Списки участников, или нажмите кнопку [image] на панели инструментов, или нажать сочетание клавиш Ctrl+E. Будет открыто окно мастера подготовки экзамена:

Мастер подготовки экзамена

Данный мастер предназначен для подготовки:

1. Списка участников, сдающих выбранный экзамен в текущем ППЭ.
2. Списка аудиторий для рассадки экзаменуемых.
3. Списка работников ППЭ (организаторов), которые будут принимать участие в организации и проведении экзамена.

Работа мастера разделена на три последовательных этапа указанных выше. Вверху рабочей области мастера указано название ППЭ и экзамен, по которому составляются списки.

Название ППЭ и экзамена

Ниже расположены названия списков, которые необходимо подготовить.

Подготавливаемые списки

Название списка, который заполняется на текущем шаге отображается в виде нажатой кнопки (на рисунке выше указан активный список «Участники»).

Во левой части рабочей области мастера располагаются данные из которых формируется списки. Составленные списки отображаются в правой части рабочей области.

Работа мастера всегда начинается с подготовки списка участников экзамена.


Подготовка списка участников экзамена

На первом шаге работы мастера необходимо составить список участников, которые будут сдавать указанный экзамен в ППЭ.

Подготовка списка участников

В левой части рабочей области находится список участников, которые еще не включены в список распределения, а так же дерево условий отбора таких учащихся.

В правой части рабочей области находится список распределения, т.е. участники которые будут сдавать выбранный экзамен в текущем ППЭ.

Выбор в дереве узла «Приписанные к ППЭ на выбранный экзамен» отбирает в список участников по сумме следующих условий:

1. Участник выбрал текущий предмет и дату сдачи.
В нашем случае предмет — география, дата сдачи — 10.06.2011.
2. Участник приписан к ОУ, которое, в свою очередь, приписано к текущему ППЭ.
В нашем случае все участники из ОУ с кодом 002710, а это ОУ приписано на географию к ППЭ с кодом 2701.
3. Участник не внесен ни в один список распределения на выбранную дату.
В нашем случае, ни один из участников из левого списка не внесен ни в один список распределения на 10.06.2011. Т.е. если бы Гуськова Т.А. была бы внесена в список распределения, скажем, по обществознанию на 10.06.2011, то ее фамилия не отобразилась бы в списке.

Если выбрать один из дочерних узлов узла «Приписанные к ППЭ на выбранный экзамен», то к вышеперечисленным условиям добавится еще одно:

· Участник приписан к выбранному ОУ.

Ниже узла «Приписанные к ППЭ на выбранный экзамен» идет список АТЕ, а в каждом АТЕ список ОУ, в которых зарегистрирован хотя бы один участник ЕГЭ (или ГИА9, если делается распределение по ГИА9). Если выбрать узел АТЕ, то в список будут отобраны участники по сумме следующих условий:

1. Участник приписан к ОУ выбранного района.
2. Участник не внесен ни в один список распределения на выбранную дату.
В нашем случае, ни один из участников из левого списка не внесен ни в один список распределения на 10.06.2011.

Т.е. отбор по АТЕ более «мягкий», т.к. не учитывается выбор экзаменов. Если раскрыть узел АТЕ и выбрать конкретное ОУ, то отбор будет выполнен по сумме следующих условий:

1. Участник приписан к выбранному ОУ.
2. Участник не внесен ни в один список распределения на выбранную дату.
В нашем случае, ни один из участников из левого списка не внесен ни в один список распределения на 10.06.2011.

Для того чтобы добавить участника в список распределения выделите его в левом списке и нажмите кнопку ArrowLeft.

Для того чтобы добавить всех участников из левого списка в список распределения нажмите кнопку ArrowsLeft.

Для того чтобы удалить учащегося из списка распределения выделите его в правом списке и нажмите кнопку ArrowRight.

Для того чтобы удалить всех участников из списка распределения нажмите кнопку ArrowsRight.

После того, как список распределения учащихся будет сформирован нажмите кнопку Далее в правом нижнем углу формы, чтобы перейти к формированию списка аудиторий.


Подготовка списка аудиторий для экзамена

На втором шаге работы мастера необходимо составить список аудиторий, которые будут использоваться на указанном экзамене.

Подготовка списка аудиторий

В левой части рабочей области находится список аудиторий ППЭ, которые еще не зарезервированы для проведения экзамена на выбранную дату (в нашем случае это 10.06.2011).

В правой части рабочей области находится список аудиторий, зарезервированных для проведения выбранного экзамена (в нашем случае это география, сдаваемая 10.06.2011).

Если в один и тот же день проводится несколько экзаменов (например, 10.06.2011 проводится география и обществознание), то аудиторию можно зарезервировать только на один из предметов. Нельзя в одной и той же аудитории в один и тот же день проводить разные экзамены.

Для того чтобы зарезервировать аудиторию для проведения экзамена выделите ее в левом списке и нажмите кнопку ArrowLeft.

Для того чтобы зарезервировать все аудитории из левого списка нажмите кнопку ArrowsLeft.

Для того чтобы удалить аудиторию из списка резервирования выделите ее в правом списке и нажмите кнопку ArrowRight.

Для того чтобы удалить все аудитории из списка резервирования нажмите кнопку ArrowsRight.

Если в список экзаменуемых были включены участники, для которых требуется специализированная рассадка, то для таких участников нужно выделить аудитории из числа зарезервированных. Внизу списка зарезервированных аудиторий отображается требуемое количество посадочных мест для обычного и специализированного распределения. Необходимо зарезервировать на экзамен такое количество аудиторий, чтобы суммарное число посадочных мест в них было достаточно для проведения обычного и специализированного распределения. Если число посадочных мест для какого-либо распределения будет недостаточным, то соответствующая итоговая строка будет выделена красным цветом.

Для того чтобы зарезервированная аудитория использовалась для специализированного распределения нужно установить пометку в колонке «Предназначена для спец. рассадки» в правом списке. Пометка устанавливается щелчком левой клавиши мыши:

Использовать аудиторию для спецрассадки

Список посадочных мест в аудитории составляется на подготовительном этапе при регистрации пунктов проведения экзаменов. При резервировании аудитории для проведения экзамена можно некоторые посадочные места в аудитории пометить как неиспользуемые. Для этого в правом списке выберите номер интересующей аудитории. Затем наведите курсор мыши на номер посадочного места в аудитории и дважды нажмите левую кнопку мыши:

Не использовать посадочное место

Повторное двойное нажатие левой клавиши мыши пометит посадочное место как используемое на экзамене. Данный способ пометки неиспользуемых мест относится только к текущему экзамену.

После того, как список аудиторий, зарезервированных для проведения экзамена, будет сформирован нажмите кнопку Далее в правом нижнем углу формы, чтобы перейти к подготовке списка работников ППЭ.


Подготовка списка работников

На третьем шаге работы мастера необходимо составить работников, которые будут участвовать в организации и проведении экзамен в ППЭ.

Подготовка списка работников

В левой части рабочей области находится список работников, которые еще не включены в список задействованных на экзамене, а так же дерево условий отбора таких работников.

В правой части рабочей области находится список работников, участвующих в проведении экзамена.

Выбор в дереве узла «Не предметники» отбирает в список работников по сумме следующих условий:

1. В списке предметов специализации работника ППЭ нет текущего предмета.
В нашем случае предмет это география.
2. Участник еще не выбран в качестве организатора экзамена на текущую дату.
В нашем случае, ни один из работников из левого списка еще не записан в организаторы эказменов на 10.06.2011.

Если выбрать один из дочерних узлов узла «Не предметники» , то к вышеперечисленным условиям добавится еще одно:

· В списке допустимых ролей работника отмечена выбранная роль.

Если выбрать узел «Все работники», то в списке будут отображены все работники ППЭ, которые еще не записаны в качестве организатора экзамена на текущую дату.

Если выбрать дочерний узел узла «Все работники», то в списке будут отображены все все работники ППЭ, которые еще не записаны в качестве организатора экзамена на текущую дату и имеют в списке допустимых ролей выбранную роль.

В итоговых строках правого списка показывается количество организаторов в аудитории, которое необходимо для проведения экзамена. Это количество рассчитывается на основании зарезервированных для экзамена аудиторий и количества посадочных мест в них.

Чтобы добавить руководителя ППЭ выберите в левом списке работника и нажмите кнопку [image]. Руководитель ППЭ назначается на текущую дату проведения экзаменов. Если в один и тот же день проводится несколько экзаменов, то руководитель будет один и тот же. На разные даты можно назначать разных руководителей.

Чтобы назначить организатора в аудитории выберите работника в левом списке и нажмите кнопку [image]. Организатор в аудитории назначается на текущий экзамен. Для каждого экзамена составляется свой список организаторов в аудиториях. Работники из списка организаторов в аудиториях будут использованы для назначения ответственных организаторов и их помощников в аудитории. Те кто не будет распределен по аудиториям будут переведены в категорию «организатор вне аудитории».

Чтобы назначить организатора вне аудитории (дежурный по этажам) выберите в левом списке работника и нажмите кнопку [image]. Дежурный по этажм назначается на текущую дату проведения экзаменов, а не на конкретный экзамен.

Чтобы назначить ассистента выберите в левом списке работника и нажмите кнопку [image]. Ассистент назначается на текущую дату проведения экзаменов, а не на конкретный экзамен.

Чтобы назначить уполномоченного представителя ГЭК выберите в левом списке работника и нажмите кнопку [image]. Уполномоченный представитель ГЭК назначается на текущую дату проведения экзаменов, а не на конкретный экзамен.

Чтобы назначить общественного наблюдателя выберите в левом списке работника и нажмите кнопку [image]. Общественный наблюдатель назначается на текущую дату проведения экзаменов, а не на конкретный экзамен.

После того, как список организаторов будет подготовлен нажмите кнопку Сохранить в правом нижнем углу формы, чтобы завершить работу мастера и перейти к следующему шагу.


Передача данных приписки в ППЭ

После того, как будут подготовлены списки экзаменуемых, задействованных работников ППЭ и используемых аудиторий необходимо передать эти списки в ППЭ. Для передачи сведений нужно выполнить экспорт распределения в файлы для ППЭ. Подготовленные таким образом файлы передаются в пункты проведения экзамена. Выполнение распределения по посадочным местам будет выполняться в ППЭ.


Выполнение распределения

Данный этап должен выполняться на уровне ППЭ.

После того как из МОУО были получены списки экзаменуемых, организаторов и используемых аудиторий можно выполнять распределение участников и организаторов по аудиториям:

1. Загрузите файл с данными по распределению.
2. Откройте модуль распределения.
3. Выберите в дереве свой пункт проведения экзамена.

Выбор ППЭ

4. Затем из расписания нужно выбрать экзамен, по которому будет выполняться распределение. Для этого используйте поле в верхней части рабочей области:
Экзамен, по которому выполняется распределение

Вы должны увидеть список экзаменуемых, работников ППЭ и аудиторий, которые были составлены в МОУО.
5. Для запуска процедуры автоматического распределения выберите пункт меню Данные—Распределить, или нажмите кнопку [image] на панели инструментов, или нажмите сочетание клавиш Ctrl+N. На экран будет выведен запрос на выполнение автоматического распределения:

Запрос на выполнение распределения

Ответьте утвердительно для запуска процедуры распределения или отрицательно для отмены запуска.

Перед началом распределения будет выполнена проверка на возможность выполнения распределения. Необходимыми условиями являются:

1. Наличие достаточного числа посадочных мест для экзаменуемых.
2. Наличие достаточного числа организаторов в аудитории для назначения ответственных организаторов и их помощников.

Если какое-то условие не будет выполняться, то на экран будет выведено предупреждение (см. рисунки ниже) и процедура распределения будет отменена.

Предупреждение о недостаточном количестве организаторов

Предупреждение о недостаточном количество посадочных мест

Если все условия, необходимые для выполнения процедуры распределения, выполняются то будет выполнена рассадка учащихся по посадочным местам и назначение организаторов в аудитории. При этом в каждую использованную для рассадки учащихся аудиторию из числа работников с ролью «Организатор в аудитории» будет случайным образом назначен ответсвенный организатор плюс один помощник на каждые 15 участников в аудитории. Если останутся нераспределенные работники с ролью «Организатор в аудитории», то им будет присвоена роль «Организатор вне аудитории» .

По окончании распределения будет выведено сообщение о завершении работы процедуры:

Распределение завершено

Сообщение «использован строгий алгоритм» означает, что ученики из одного класса не сидят на смежных местах. Если такая рассадка не возможна, то используется рассадка учащихся по аудиториям в случайном порядке.

Для того чтобы очистить распределение (отписать участников от посадочных мест, а работников от аудиторий) выберите пункт меню Данные—Очистить, или нажмите кнопку [image] на панели инструментов, или нажмите сочетание клавиш Ctrl+D.

После того как распределение выполнено распечатайте все необходимые формы и передайте данные по распределению вышестоящей организации.


Печать отчетных форм и списков

Обращаем ваше внимание, что существует ряд печатных форм, которые в обязательном порядке должны быть переданы в РЦОИ из пунктов проведения экзаменов вместе с материалами экзамена. Список форм приведен в документах «Методические материалы по подготовке и проведению ЕГЭ в пунктах проведения экзамена в 2011 году» и «Сводный реестр форм ППЭ, формируемых во время проведения экзамена».

Часть форм формируются программой. Для печати таких форм в модуле распределения выберите пункт меню Отчеты и распечатайте нужную форму.

Для ускорения процедуры приемки данных в РЦОИ можно на упаковочные конверты с материалами экзамена наклеить специальные наклейки со штрих-кодами. В штрих-коде шифруются сведения о типе бланков, количестве бланков, предмете и дате экзамена. Наклейки печатаются в ППЭ по окончании экзамена. Печать нужно производить на струйном или лазерном принтере.

Для того, чтобы использовать наклейки со штрих-кодами должны быть выполнены следующие условия:

1. Распределение учащихся должно быть выполнено.
2. Учащиеся написали экзамен согласно схеме распределения.
3. Бланки собраны и упакованы в доставочные пакеты.
4. Формы на доставочных пакетах заполнены верными сведениями.

Если все условия выполнены, то можно распечатать наклейки для доставочных пакетов. Для этого:

1. Откройте модуль распределения текущего экзамена

Распределение по ППЭ 2701 на 10.06.11 по географии
2. Выберите пункт меню Отчеты—Печать наклеек, будет открыто окно печати наклеек

Окно настройки печати наклеек
3. Скорректируйте общее количество бланков по аудиториям. Количество бланков по аудиториям, указанное в форме печати, должно совпадать с общим числом бланков в соответсвующих пакетах. Т.е., берем доставочный пакет, смотрим сколько в нем бланков и какого типа, и если это число отличается от указанного в форме (для этой же аудитории и этого типа бланков), то исправляем данные в форме. Обязательно проверьте количество по бланкам ответов №2. Если в аудитории использовались дополнительные бланки ответов, значит количество бланков в пакете будет больше, чем в форме печати наклеек по этой аудитории. Указывать нужно общее число бланков в доставочном пакете.
4. Когда количество бланков по всем аудиториям будет скорректировано нажмите кнопку Печать, будет открыто окно предварительного просмотра печатной формы (в нашем примере было изменено количество бланков ответов №2 в аудиториях №30 и №33)

Предварительный просмотр наклеек
5. Для печати наклеек нажмите кнопку [image] на панели инструментов. Печать нужно выполнять на лазерном или струйном принтере. Принтер не должен «мазать», печать штрих-кодов должна быть четкой.
6. Распечатанный лист (листы) разрежьте на отдельные наклейки. При этом старайтесь не обрезать рамку наклейки. Лини разреза показаны на рисунке ниже

Линии разреза
7. Наклейки следует клеить в правый нижний угол лицевой стороны упаковочного конверта
pack
Размещение наклейки на пакете


Передача данных распределения в МОУО

Для передачи данных в другую организацию необходимо экспортировать эти данные в файл.

Из ППЭ данные распределения могут передаваться в МОУО.

Для этого:

1. Откройте окно экспорта данных.
2. Выберите тип экспорта «В один файл для передачи вышестоящей организации».
3. Пометьте дату, на которую делалось распределение.
4. Экспортируйте данные в файл.

Руководство по экспорту данных в пункте проведения экзамена приведено в разделе «Экспорт данных ППЭ водин файл».

МОУО может передавать данные по распределению в ППЭ и в РЦОИ. Алгоритм экспорта данных совпадает с алгоритмом экспорта данных в пункте проведения экзамена (см. выше), за исключением п. 2. На втором шаге нужно выбрать нужный вид экспорта (в один файл или в разные файлы для ППЭ). Более подробно процедуры экспорта данных в МОУО описаны в разделах «Экспорт данных АТЕ в файлы для ППЭ» и «Экспорт данных АТЕ в один файл».


Импорт данных

Процедура импорт данных предназначена для загрузки данных из файла в БД.

В программе предусмотрено два вида импорта данных:

1. Импорт данных из файлов внутреннего формата.
Данный вид импорта используется при проведении первого этапа ЕГЭ и для регистрации программы на организацию.
2. Импорт данных из текстовых файлов заданного формата.
Данный вид импорта используется при проведении второго этапа ЕГЭ (июль). В частности используется для загрузки данных, сформированных другими программами. Описание формата файла можно получить на сайте РЦОИ в разделе «Сервис файлообмена».


Импорт данных из формата РБД

Процедура импорт данных предназначена для загрузки данных из файла в БД. Кроме того, при импорте первого файла выполняется внесение регистрационных данных в базу. Регистрация необходима для корректной работы программы.

Перед началом импорта рекомендуется закрыть все открытые справочники, т.к. после окончания импорта отображаемые на экране данные автоматически не обновляются, что может создать иллюзию неверной работы функции импорта.

Для запуска процесса импорта выберите пункт меню Файл—Импорт—Импорт файлов данных (рис.Запуск импорта ).

Запуск импорта

Далее выделите файлы, которые необходимо импортировать (рис. Выбор файлов импорта). Допускается выбор нескольких файлов. Например, при выполнения в МОУО импорта файлов полученных из ОУ можно выделить сразу несколько файлов. Импорт будет выполняться последовательно для каждого выбранного файла. При выполнении регистрации программы следует выбирать только один файл, соответствующий вашей организации.

Выбор файлов импорта

После выбора файла нажмите кнопку открыть. Будет открыто окно со списком данных, которые содержатся в файле (рис. Список импорта). Если программа еще не зарегистрирована, то следует установить все пометки, для импорта всех данных, включая Регистрационные данные БД.

Список импорта

После выбора данных для импорта (рис. Выбор импортируемых данных) нажмите кнопку «Импорт».

Выбор импортируемых данных

Данные, которые не выбраны, импортироваться не будут. Данная возможность предусмотрена для частичного обновления. Например для обновления данных по АТЕ в ОУ, без изменения данных по учителям и ученикам.

Регистрационные данные БД отображаются для выбора только в том случае, если программа еще не зарегистрирована.

Флаг Заменить данные в БД данными из файла предназначен для переключения режима импорта. Предусмотрено два режима:

1. Обновление данных — флаг Заменить данные в БД данными из файла снят. Этот режим предназначен для изменения и дополнения данных в БД данными из файла. Если в файле будет отсутствовать учитель или ученик, который есть в базе, то он останется в базе без изменений.
2. Замена данных — флаг Заменить данные в БД данными из файла установлен. Это режим предназначен для замены данных в БД данными из файла. Если в базе есть данные на какого-то ученика/учителя, а в файле нет данных на этого ученика/учителя, то такой ученик/учитель будет удален из базы, если это возможно. Для ученика удаление не возможно, если он зарегистрирован в рассадке на экзамен, для учителя удаление не возможно, если он зарегистрирован в условиях обучения. Записи, которые удалить невозможно, будут оставлены в БД.

Сведения по АТЕ, МОУО, ОУ всегда импортируются в режиме обновления.

При импорте распределения анкетные данные экзаменуемых и работников ППЭ всегда импортируются в режиме обновления.

При импорте распределения данные распределения экзаменуемых и работников ППЭ всегда импортируются в режиме замены данных.

Кнопки в левой нижней части окна [image] предназначены для управления группой пометок.

Когда будет нажата кнопка Далее, в нижней части окна появится индикатор процесса импорта данных (рис. Процесс импорта). Для данных, импорт которых уже прошел, пометка снимается.

Процесс импорта

Если в процессе импорта произойдет ошибка, то на экран будет выведено сообщение об ошибке.

Сообщение об ошибке

Если импорт был успешен и имеется еще один выбранный файл доя импорта, то будет открыто окно «Список импорта» для нового файла.

Если других файлов для импорта нет, то будет выведено сообщение «Импорт завершен».

Импорт завершен


Импорт данных из текстового формата (июльский этап)

Процедура импорт данных из текстового файла предназначена для загрузки данных из файла в БД. Данный вид импорта используется на этапе подготовки дополнительного этапа ЕГЭ. На дополнительном этапе обмен данными между организаторами производится с использованием текстовых файлов заданного формата.

Для запуска процесса импорта данных из текстового файла выберите пункт меню Файл—Импорт—Импорт участников 2 волны (рис.Запуск импорта ).

Запуск импорта

Далее выделите файлы, которые необходимо импортировать (рис. Выбор файлов импорта). Допускается выбор нескольких файлов.Импорт будет выполняться последовательно для каждого выбранного файла.

Выбор файлов импорта

После выбора файла нажмите кнопку открыть. Перед импортом каждого из выбранных файлов запускается процедура проверки корректности данных. По окончании проверки файла на экран выводится окно с результатами проверки (рис. Результаты проверк корректности файла). Если будут обнаружены некорректные данные, то будет отображены номера строк с ошибочными данными и описание ошибки. В конце списка выводится сообщение о количестве данных, которые прошли проверку на корректность и могут быть загружены в БД.

Результаты проверки корректности файла

Для загрузки корректных данных в БД нужно нажать кнопку Импорт.

При загрузке данных в БД для каждой записи из файла производится поиск похожей записи в базе данных. Если в БД находится участник у которого совпадают анкетные данные (ФИО, тип документа, серия и номер документа, пол), то считается что запись в файле соответствует участнику из БД. Для таких записей происходит «склеивание» выбранных для сдачи экзаменов. Данные в базе дополняются данными из файла. Если в файле по какому-то из экзаменов указана дата, отличная от даты в БД, то данные в БД будут заменены данными из файла. Если в БД есть запись на экзамен, а в файле нет, то запись на экзамен в БД останется неизменной.

Если в БД будет обнаружена запись (или несколько записей) «похожая» на запись из файла, то на экран будет выведено окно для выбора оператором алгоритма обработки текущей строки:

Окно выбора способа обработки записи

Поиск похожих записей в БД выполняется по следующим критериям:

1. Совпадение по ФИО, и номеру документа.
2. Совпадение по фамилии, имени и номеру документа.
3. Совпадение по фамилии и номеру документа.
4. Совпадение по номеру документа.
5. Совпадение по ФИО.
6. Совпадение по фамилии и имени.
7. Совпадение по фамилии.

Если ни по одному из вышеперечисленных критериев не будет найдена запись в БД, то считается что в файле содержатся данные на нового участника, и его данные будут добавлены в БД. Если будет найдена хотя бы одна запись в базе, и при этом будут какие-то различия с анкетными данными из файла, то будет выведено окно выбора способа обработки (см. рисунок выше).

В верхней части окна представлены данные участника из файла, внизу показаны записи, которые найдены в БД по одному из критериев поиска. При автоматическом поиске перебираются все семь критериев в том порядке, как они представлены выше. Критерии перебираются до тех пор, пока не будет найдена хотя бы одна запись, или пока не закончится список критериев. Название критерия последнего использованного критерия отображается в поле Поиск записей в БД по. В открытом окне вы можете попытаться самостоятельно поискать подходящие записи в БД по для текущего участника. Для этого выберите критерий из списка и нажмите кнопку Искать.

При обнаружении в БД записей, похожих на данные участника из файла вы можете выбрать одно из трех действий:

1. Добавить в БД новую запись для участника из файла (кнопка Добавить в БД).
Данный вариант следует использовать в том случае, если вы уверены, что данные в файле не соответствуют ни одной из найденных записей.
2. Выбрать среди найденных записей ту, которая соответствует данным из файла и использовать эти данные (кнопка Выбрать из БД).
Данный вариант следует использовать в том случае, если в базе данных обнаружены корректные данные на участника, а в файле содержатся данные с ошибкой/опечаткой.
3. Выбрать среди найденных записей ту, которая соответствует данным из файла и заменить эти данные (кнопка Изменить в БД).
Данный вариант следует использовать в том случае, если в базе данных обнаружены некорректные данные на участника, а в файле содержатся правильные данные.

Следует отметить, что код ОУ не обязательно должен совпадать у одного и того же участника. Если два образовательных учреждения подадут сведения на одного и того же участника, то код ОУ у одного и того же участника в разных файлах будет разным. При сравнении записей код ОУ не используется, проверка ведется только по ФИО и паспортным данным. В автоматическом режиме код ОУ для существующей записи в БД не изменяется. Если же оператор выбирает кнопку Изменить в БД, то код в базе будет изменен.

После импорта файл переименовывается по шаблону 22_??????.CS_.OK, даже если вы отказались от импорта файла из-за наличия в нем ошибок. Кроме того, в процессе импорта создается файл 22_??????.CS_.LOG, в котором отображаются все ошибки, все добавленные или измененные в БД записи.

После импорта всех выбранных файлов будет выведено сообщение «Импорт завершен».

Импорт завершен


Экспорт данных

Операция экспорта предназначена для выгрузки данных в один или несколько файлов.

Данные в файлы записываются в сжатом виде. Поэтому при передаче файлов из одной организации в другую дополнительную упаковку файлов при помощи программ сжатия производить не следует.

Список данных, доступный для экспорта в организации приведен в таблице «Редактируемые данные и рекомендации по заполнению». Список доступных видов экспорта приведен в таблице ниже:

Тип организации

Экспорт в один файл

Экспорт в разные файлы с делением по ОУ

Экспорт в разные файлы с делением по ППЭ

Образовательное учреждение

Экспорт данных ОУ в один файл предназначен для передачи данных из ОУ в МОУО.

Данные выгружаются в файл с именем SCH_XXXXXX.EXP, где XXXXXX — код ОУ.

В файл выгружаются данные по тому ОУ, на которое зарегистрирована программа.
В файл можно выгрузить:

· данные по ОУ из справочника образовательных учреждений;
· данные по учителям образовательного учреждения,
· данные по участникам ЕГЭ и ГИА9, которые зарегистрированы в ОУ.

Для ОУ не предусмотрен данный вид экспорта

Для ОУ не предусмотрен данный вид экспорта

Пункт проведения экзамена

Экспорт данных ППЭ водин файл предназначен для передачи данных из ППЭ в МОУО.

Данные выгружаются в файл с именем STN_XXXXXX.EXP, где XXXXXX — код ППЭ. В файл выгружаются данные по ППЭ, на которое зарегистрирована программа, а так же список работников. Кроме того, данный вид экспорта предназначен для передачи в МОУО данных о распределении участников и работников на экзамен.

В файл можно выгрузить:

· данные по ППЭ;
· данные по работникам;
· данные по распределению участников и работников на экзамен.

Для ППЭ не предусмотрен данный вид экспорта

Для ППЭ не предусмотрен данный вид экспорта

Муниципальный орган управления образованием (регистрация программы производится на АТЕ, на территории которой располагается МОУО)

Экспорт данных АТЕ в один файл предназначен для передачи данных из МОУО в РЦОИ.

Данные выгружаются в файл с именем ARE_XXXXXX.EXP, где XXXXXX — код АТЕ, в котором расположено МОУО.

В файл выгружаются данные по тому АТЕ, на которое зарегистрирована программа.
В файл можно выгрузить:

· данные по АТЕ, на которую зарегистрирована программа;
· данные по МОУО, расположенного на территории АТЕ;
· данные по всем образовательным учреждениям АТЕ;
· данные по учителям образовательных учреждений района;
· данные по участникам ЕГЭ и ГИА9, которые зарегистрированы в образовательных учреждениях района.

Экспорт данных АТЕ в файлы для ОУ предназначен для передачи данных из МОУО в ОУ.

Данные выгружаются в файлы с именем SCH_XXXXXX.EXP, где XXXXXX — код ОУ.

Для каждого образовательного учреждения из АТЕ будет создан отдельный файл с данными. В обязательном порядке в файл будет включена регистрационная информация, позволяющая произвести регистрацию программы при первом импорте.

Дополнительно можно выгрузить:

· данные по АТЕ, на которую зарегистрирована программа;
· данные по МОУО региона;
· данные по образовательному учреждению, для которого формируется файл;
· данные по учителям образовательного учреждения;
· данные по участникам ЕГЭ и ГИА9, которые зарегистрированы в образовательном учреждении.

Экспорт данных АТЕ в файлы для ППЭ предназначен для передачи данных из МОУО в ППЭ.

Данные выгружаются в файл с именем STN_XXXXXX.EXP, где XXXXXX — код ППЭ.

Для каждого пункта проведения экзамена из АТЕ будет создан отдельный файл с данными. В обязательном порядке в файл будет включена регистрационная информация, позволяющая произвести регистрацию программы при первом импорте.

Дополнительно можно выгрузить:

· данные по АТЕ, на которую зарегистрирована программа;
· данные по МОУО региона;
· данные по всем ОУ АТЕ;
· данные по пункту проведения экзамена, для которого формируется файл;
· данные по распределению участников и работников на экзамен.

При расширении возможностей программы список экспорта будет пополнен.

Подробную инструкцию экспорта данных смотрите в соответствующих разделах:

· «Экспорт данных ОУ в один файл» — раздел для операторов в ОУ,
· «Экспорт данных ППЭ водин файл» — раздел для операторов в ППЭ,
· «Экспорт данных АТЕ в один файл», «Экспорт данных АТЕ в файлы для ОУ» и «Экспорт данных АТЕ в файлы для ППЭ» — разделы для операторов в МОУО.


Экспорт данных ОУ в один файл

Данный вид экспорта предназначен для передачи данных из ОУ в МОУО.

Данные выгружаются в файл с именем SCH_XXXXXX.EXP, где XXXXXX — код ОУ.

В файл выгружаются данные по тому ОУ, на которое зарегистрирована программа.
В файл можно выгрузить:

· данные по ОУ из справочника образовательных учреждений;
· данные по учителям образовательного учреждения,
· данные по участникам ЕГЭ и ГИА9, которые зарегистрированы в ОУ.

Для запуска процедуры экспорта выберите пункт меню Файл—Экспорт—Экспорт данных. В открывшемся окне «Параметры экспорта» сделайте настройки экспорта.

Параметры экспорта

Укажите папку, в которой будет создан файл экспорта.

В ОУ доступен единственный вид экспорта, который выбран по умолчанию.

Пометьте данные, которые нужно экспортировать в файл. Кнопки в левой нижней части окна предназначены для управления группой меток. Рекомендуется всегда выгружать в файл данные по ученикам совместно с данными по учителям. В противном случае при импорте данных из файла могут возникнуть ошибки, если в базе назначения будет отсутствовать учитель, на которого есть ссылки в условиях обучения.

После указания всех необходимых параметров экспорта нажмите кнопку Экспорт.

В нижней части окна будет отображать прогресс выгрузки таблиц. По завершении экспорта будет выведено окно «Окончание экспорта».

Окончание экспорта

В указанной вами папке будет создан файл SCH_XXXXXX.EXP, где XXXXXX — код ОУ, на которое зарегистрирована программа.


Экспорт данных ППЭ водин файл

Данный вид экспорта предназначен для передачи данных из ППЭ в МОУО.

Данные выгружаются в файл с именем STN_XXXXXX.EXP, где XXXXXX — код ППЭ.

В файл выгружаются данные по тому ППЭ, на которое зарегистрирована программа.
В файл можно выгрузить:

· данные по ППЭ;
· данные по работникам ППЭ,
· данные по распределению участников и работников на экзамен.

Для запуска процедуры экспорта выберите пункт меню Файл—Экспорт—Экспорт данных. В открывшемся окне «Параметры экспорта» сделайте настройки экспорта.

Параметры экспорта

Укажите папку, в которой будет создан файл экспорта.

В ППЭ доступен единственный вид экспорта, который выбран по умолчанию.

Пометьте данные, которые нужно экспортировать в файл. Кнопки в левой нижней части окна предназначены для управления группой меток.

При экспорте руководствуйтесь следующими замечаниями:

1. Данные по ППЭ следует экспортировать в том случае, если в ППЭ редактировали данные по пункту проведения экзамена (о редактировании данных ППЭ см. раздел «Изменение данных ППЭ»).
2. Данные распределений группируются по датам экзаменов. В данные по распределению включены анкетные данные экзаменуемых и работников, которые участвуют в распределении. Поэтому, если в ППЭ были внесены коррективы в анкетные данные экзаменуемых или в анкетные данные работников ППЭ, задействованных в проведении экзамена, то все эти изменения будут автоматически переданы в МОУО вместе с данными по распределению.

После указания всех необходимых параметров экспорта нажмите кнопку Экспорт.

В нижней части окна будет отображать прогресс выгрузки таблиц. По завершении экспорта будет выведено окно «Окончание экспорта».

Окончание экспорта

В указанной вами папке будет создан файл STN_XXXXXX.EXP, где XXXXXX — код ППЭ, на которое зарегистрирована программа.


Экспорт данных АТЕ в один файл

Данный вид экспорта предназначен для передачи данных из МОУО в РЦОИ.

Данные выгружаются в файл с именем ARE_XXXXXX.EXP, где XXXXXX — код АТЕ, в котором расположено МОУО.

В файл выгружаются данные по тому АТЕ, на которое зарегистрирована программа.
В файл можно выгрузить:

· данные по АТЕ, на которую зарегистрирована программа;
· данные по МОУО, расположенного на территории АТЕ;
· данные по всем образовательным учреждениям АТЕ;
· данные по учителям образовательных учреждений района;
· данные по участникам ЕГЭ и ГИА9, которые зарегистрированы в образовательных учреждениях района.

Для запуска процедуры экспорта выберите пункт меню Файл—Экспорт—Экспорт данных. В открывшемся окне «Параметры экспорта» сделайте настройки экспорта.

Параметры экспорта

Укажите папку, в которой будет создан файл экспорта.

Укажите вид экспорта «В один файл для передачи вышестоящей организации».

Пометьте данные, которые нужно экспортировать в файл. Кнопки в левой нижней части окна предназначены для управления группой меток. Рекомендуется всегда выгружать в файл данные по ученикам совместно с данными по учителям. В противном случае при импорте данных из файла могут возникнуть ошибки, если в базе назначения будет отсутствовать учитель, на которого есть ссылки в условиях обучения.

После указания всех необходимых параметров экспорта нажмите кнопку Экспорт.

В нижней части окна будет отображать прогресс выгрузки таблиц. По завершении экспорта будет выведено окно «Окончание экспорта».

Окончание экспорта

В указанной вами папке будет создан файл ARE_XXXXXX.EXP, где XXXXXX — код АТЕ, на которую зарегистрирована программа.


Экспорт данных АТЕ в файлы для ОУ

Данный вид экспорта предназначен для передачи данных из МОУО в ОУ.

Данные выгружаются в файлы с именем SCH_XXXXXX.EXP, где XXXXXX — код ОУ.

Для каждого образовательного учреждения из АТЕ будет создан отдельный файл с данными. В обязательном порядке в файл будет включена регистрационная информация, позволяющая произвести регистрацию программы при первом импорте.

Дополнительно можно выгрузить:

· данные по АТЕ, на которую зарегистрирована программа;
· данные по МОУО, расположенного на территории АТЕ;
· данные по образовательному учреждению, для которого формируется файл;
· данные по учителям образовательного учреждения;
· данные по участникам ЕГЭ и ГИА9, которые зарегистрированы в образовательном учреждении.

Для запуска процедуры экспорта выберите пункт меню Файл—Экспорт—Экспорт данных. В открывшемся окне «Параметры экспорта» сделайте настройки экспорта.

Параметры экспорта

Укажите папку, в которой будут созданы файлы экспорта.

Укажите вид экспорта «Делить по ОУ для передачи в образовательные учреждения».

Пометьте данные, которые нужно экспортировать в файл. Кнопки в левой нижней части окна предназначены для управления группой меток. Рекомендуется всегда выгружать в файл данные по ученикам совместно с данными по учителям. В противном случае при импорте данных из файла могут возникнуть ошибки, если в базе назначения будет отсутствовать учитель, на которого есть ссылки в условиях обучения.

После указания всех необходимых параметров экспорта нажмите кнопку Экспорт.

В нижней части окна будет отображать прогресс выгрузки таблиц. По завершении экспорта будет выведено окно «Окончание экспорта».

Окончание экспорта

В указанной вами папке будут созданы файлы SCH_XXXXXX.EXP, где XXXXXX — код ОУ, для которого предназначен файл.


Экспорт данных АТЕ в файлы для ППЭ

Данный вид экспорта предназначен для передачи данных из МОУО в ППЭ.

Данные выгружаются в файлы с именем STN_XXXXXX.EXP, где XXXXXX — код ППЭ.

Для каждого пункта проведения экзамена из АТЕ будет создан отдельный файл с данными. В обязательном порядке в файл будет включена регистрационная информация, позволяющая произвести регистрацию программы при первом импорте.

Дополнительно можно выгрузить:

· данные по АТЕ, на которую зарегистрирована программа;
· данные по МОУО региона;
· данные по всем ОУ АТЕ;
· данные по пункту проведения экзамена, для которого формируется файл;
· данные по работникам ППЭ;
· данные по участникам ЕГЭ и ГИА9 всего района (с указанием выбранных для сдачи предметов, но без условий обучения)
· данные по распределению участников и работников на экзамен.

Для запуска процедуры экспорта выберите пункт меню Файл—Экспорт—Экспорт данных. В открывшемся окне «Параметры экспорта» сделайте настройки экспорта.

Параметры экспорта

Укажите папку, в которой будут созданы файлы экспорта.

Укажите вид экспорта «Делить по ППЭ для передачи в пункты проведения экзамена».

Пометьте данные, которые нужно экспортировать в файл. Кнопки в левой нижней части окна предназначены для управления группой меток.

При создании регистрационных файлов для ППЭ, следует выгрузить в этот файл все данные.

После указания всех необходимых параметров экспорта нажмите кнопку Экспорт.

В нижней части окна будет отображать прогресс выгрузки таблиц. По завершении экспорта будет выведено окно «Окончание экспорта».

Окончание экспорта

В указанной вами папке будут созданы файлы STN_XXXXXX.EXP, где XXXXXX — код ППЭ, для которого предназначен файл.


Экспорт данных в текстовый файл (июльский этап)

Передача данных по участникам дополнительного этапа (июльский этап) производится в виде текстовых файлов установленного образца. Описание формата можно найти на сайте РЦОИ в разделе «Сервис файлообмена».

Для запуска процедуры экспорта выберите пункт меню Файл—Экспорт—Экспорт участников 2 волны. В открывшемся окне «Параметры экспорта» сделайте настройки экспорта.

Параметры экспорта

Укажите папку, в которой будет создан файл экспорта.

Пометьте данные, которые нужно экспортировать в файл. Кнопки в левой нижней части окна предназначены для управления группой меток.

После указания всех необходимых параметров экспорта нажмите кнопку Экспорт.

В нижней части окна будет отображать прогресс выгрузки таблиц. По завершении экспорта будет выведено окно «Окончание экспорта».

Окончание экспорта

В указанной вами папке будет создан файл 22_XXXXXX.EXP, где XXXXXX — код ОУ/ППЭ, на которое зарегистрирована программа.


Настройки программы

Рассмотрим состав раздела меню Настройки основного окна программы:

· Использовать темы Windows.
Данный пункт переключает внешний вид окон программы.
Если не стоит пометка, то окна программы отрисовываются в классическом стиле Windows.
Если пометка стоит, то отображение окон программы максимально приближено к текущей теме Windows XP/Vista.
Следует отметить, что изменение отрисовки производится только после перезапуска программы.
· Список соединений.
Это пункт меню предназначен для вызова менеджера соединений.
· Администрирование
Подраздел для служебных модулей. В инсталляционный пакет включен служебный модуль «Менеджер модулей», который можно вызвать выбрав в подразделе пункт меню Менеджер модулей.


Менеджер соединений

Менеджер соединений используется для настройки подключения модулей программы к базе данных. Изменять настройки программы в части подключения к БД следует только при полном понимании последствий своих действий. Тем не менее, при использовании сетевой версии программы может возникнуть необходимость изменить параметры подключения к БД. Напомним, что при использовании сетевой версии, необходимо в СУБД FireBird 2.5 создать пользователя, от имени которого будет производиться все работа с БД (восстановление, работа с данными, резервное копирование и т.д.).

Логика работы менеджера подключений следующая:

1. «Программа хочет подключиться к БД». Различные модули программы запрашивают у менеджера подключения параметры соединения с БД. При этом менеджеру передается подпись-название, по которой администратор может определить соединение с какой базой нужно настроить.
2. Администратор, ориентируясь на подписи-названия требуемых программой подключений, настраивает параметры подключения. Настроенные администратором параметры сохраняются в списке соединений.
3. Затем администратор устанавливает соответствие между запрошенным соединением и настроенными параметрами подключения. Т.е. для каждого запроса указывает какие параметры подключения следует использовать.
4. Настроенный список соответствия будет использоваться менеджером для раздачи параметров подключения к БД.

Еще раз подчеркнем, что при использовании локальной версии установки программы со встроенным сервером баз данных настройка параметров подключения к БД выполняется автоматически при установке программы. Если вы скопируете папку установленной программы в новое место, то программа работать не будет. Или будет подключаться к базе данных расположенной по месту установки программы.

Итак, окно менеджера соединений состоит из двух частей:

· список соединений,
· список использования соединений.

Менеджер соединений


Список соединений

Список соединений заполняется пользователем. В этом списке хранятся параметры подключений к базам данным. При установке программы заводится одна единственная запись, описывающая подключение к вашей базе данных. При локальной установке параметры подключения генерируются автоматически, при сетевой установке используются те параметры, которые были указаны в мастере установки программы.

Для изменения параметров подключения выберите нужную запись в списке соединений и нажмите кнопку редактирования [image] на панели инструментов. В открывшемся окне укажите параметры подключения к базе данных.

Параметры подключения к БД

Подключение к БД описывается следующими параметрами:

· Сервер
DNS-имя или IP-адрес сервера, на котором установлена СУБД FireBird 2.5. Для локальной установки программы это поле остается пустым.
· Порт
Номер порта подключения к СУБД FireBird 2.5. Заполняется только для сетевой версии программы, при условии, что при установке СУБД FireBird 2.5 был указан номер порта отличный от значения по умолчанию.
· База данных
Полный путь до фала базы данных.
Если используется сетевая версия программы, то путь до БД должен соответствовать размещению файла БД в файловой системе сервера. Можно использовать алиас базы данных, при условии что в конфигурационном файле СУБД FireBird 2.5 описан этот алиас.
· Название
Название записи. Это название должно быть уникальным для каждого элемента из вашего списка соединений. Название может состоять из латинских букв и цифр. Все остальные символы использовать нельзя.
· Подпись
Подпись отображается в списке соединений. Используется для задания названия соединения понятного пользователю.
· Пользователь
Имя пользователя для подключения к БД.
В локальной версии программы следует использовать имя пользователя sysdba.
В сетевой версии программы пользователя нужно создать средствами СУБД до установки БД. И использовать имя этого пользователя для установки базы данных и подключения к базе данных из программы.
· Пароль
Пароль пользователя для подключения к БД.
В локальной установке используется слово masterkey.
В сетевой версии пароль пользователя задается при создании пользователя средствами СУБД.
· Роль
Роль пользователя в базе данных. Роль задается при установке программы. В МОУО следует использовать роль ROLEMOUO, в ОУ — роль ROLESCHOOL, в ППЭ — роль ROLESTATION.
В сетевой версии программы назначение роли пользователю производится в процессе установки базы данных. Если пользователь СУБД создан уже после установки базы данных, то ему необходимо назначить соответствующую роль средствами СУБД. Без присвоения пользователю роли в сетевой версии программы работа с БД будет не возможна.
· Библиотека доступа
Библиотека доступа к СУБД FireBird 2.5.
При использовании локальной версии программы следует использовать библиотеку fbembed.dll из состава встроенного сервера.
При использовании сетевой версии программы необходимо использовать библиотеку fbclient.dll, которая будет установлена в папку установки программы в подпапку system.


Список использования соединений

Список использования соединений состоит из двух колонок:

· Модуль, использующий соединений
В этой колонке отображается список подключений, которые нужно настроить для корректной работы программы. На рисунке приведен список из двух подписей: нужно настроить соединение с базой участников ЕГЭ и эти же параметры запрашивает модуль установки обновлений базы данных.
· Используемое соединение
Показывает какие параметры поставлены пользователем в соответствие.

Список используемых соединений

Чтобы настроить соединение с БД нужно:

1. Открыть менеджер соединений.
2. Ознакомиться со списком модулей, запрашивающих подключение к БД.
3. В списке соединений создать нужное количество записей описывающих параметры подключения к БД. В нашем случае нужна одна запись для подключения к базе данных программы
4. Выделить в списке соединений строку с параметрами подключений.
5. Выделить в списке использования соединений строку со списком запрошенных подключений.
6. Нажать кнопку [image] на панели инструментов. В правой колонке строки должна отобразиться подпись параметров подключения. Это означает, что соединение с БД настроено.

Для проверки возможности подключения к БД выполните следующие действия:

1. Выберите в списке соединений строку для проверки.
2. Нажмите кнопку Тест. Если соединение с БД будет успешным, то на экран будет выведено сообщение

В противном случае будет выведено сообщение об ошибке.


Менеджер модулей

Менеджер модулей предназначен для административных целей. Выполнять какие-то операции с менеджером можно только в том случае, если вы осознаете последствия своих действий. В частности, деактивация модулей изменяет функционал программы. Рекомендуется использовать данный модуль для просмотра версий модулей и для просмотра зависимостей между файлами программы. Например, можно развернуть все узлы дерева зависимостей и просмотреть все ли необходимые файлы доступны программе.

Ниже кратко описан функционал модуля.

Менеджер модулей предназначен для:

· деактивации модулей (отключения);
· активации модулей (подключения);
· просмотра списка зависимостей между библиотеками программы;
· копирования всех активных модулей и необходимых для корректной работы файлов клиентской части в указанную папку (база данных не копируется).

Для активации/деактивации модуля нужно установить/снять пометку возле имени модуля. Деактивированный модуль не будет загружаться при запуске программы. Деактивировать модули можно только в том случае, если вы осознаете последствия своих действий.

Список зависимостей модулей и файлов представлен в виде дереве. В узле конкретного модуля собраны все файлы, которые необходимы для корректной работы модуля.

Копирование активных модулей вместе со всеми зависимыми файлами можно использовать для создания копии обновленного рабочего места. Затем подготовленные таким образом файлы можно перенести на другие рабочие места для обновления клиентской части сетевой установки. Данная операция будет полезна при использовании сетевого варианта установки программы, когда используется несколько рабочих мест для работы с общей базой данных. Для создания копии файлов клиентской части выберите пункт меню Зависимости—Собрать дистрибутив. Следует отметить, что исторически сложившееся название пункта меню не совсем корректно, поскольку делается не дистрибутив программы в целом, а лишь копия файлов клиентской части программы. База данных не копируется.

Окно менеджера модулей


Обновление программы

В состав инсталляционного пакета программы включен модуль обновления программы, предназначенный для проверки, загрузки и установки обновлений клиентской части и базы данных.

Для корректной работы модуля необходимо подключение рабочей станции к сети Интернет одним из способов:

· прямое подключение через модем;
· подключение через шлюз без использования proxy-сервера;
· подключение через proxy-server по протоколу http без авторизации;
· подключение через proxy-server по протоколу http с использованием basic-авторизации.

Проверка обновлений программы всегда запускается по требованию пользователя.

Актуальная версия программы будет выкладываться на один из серверов РЦОИ. Адрес расположения актуальной версии программы будет сообщен дополнительно. После публикации обновленной версии по списку рассылки будет рассылаться электронное письмо с описанием изменений. При получении такого письма необходимо будет обновить программу.

Использование модуля обновления программы позволит минимизировать объем передаваемых данных.

Если по какой-либо причине автоматическое обновление не будет работать, то необходимо будет получить обновление в частном порядке по электронной почте.

Настройка параметров обновления производится при установке программы на рабочую станцию. Изменить указанные при установке параметры обновления можно в окне «Параметры обновления».

Описание процесса проверки и установки обновлений клиентской части приведено в разделе «Описание процесса обновления клиентской части».

Описание процесса проверки и установки обновлений БД приведено в разделе «Описание процесса обновления БД».

При использовании сетевой версии программы следует сначала выполнить обновление клиентской части на одной из рабочих станций, запустить программу, установить, если потребуется, обновление базы данных, и только после этого обновлять оставшиеся рабочие места.

Обновление базы данных следует всегда проводить в монопольном режиме, т.е. при обновлении БД никакие другие рабочие станции не должны быть подключены к базе данных.


Настройка параметров обновления

Для изменения параметров проверки обновлений программы выберите пункт меню ?—Параметры проверки обновлений.

В открывшемся окне укажите адрес для поиска обновлений и параметры подключения к сети Интернет.

1. Адрес для поиска обновлений.
Предоставляется региональным центром обработки информации.
2. Авторизация на сервере.
РЦОИ не планирует использовать для распространения обновлений сервера требующие авторизацию. Если будет необходима авторизация на сервере обновлений, то учетные данные будут предоставлены региональным центром обработки информации.
Сервер требует авторизацию — установите этот флаг, если сервер обновлений требует авторизацию для доступа к данным.
Имя пользователя — имя пользователя для авторизации на сервере обновлений.
Пароль — пароль пользователя для авторизации на сервере обновлений.
3. Proxy.
Данные этой группы заполняются в зависимости от способа подключения рабочей станции к сети Интернет.
Использовать proxy-сервер — установите флаг, если подключение осуществляется через proxy-сервер по протоколу http. Если proxy-сервер не используется, то флаг следует снять. Если используется proxy-сервер не поддерживающий протокол http, то работа модуля проверки обновлений будет невозможна.
Адрес и порт proxy — укажите доменный или IP адрес proxy-сервера, а так же порт подключения к proxy-серверу. Адрес задается по шаблону <адрес сервера>:<порт>. Обе части адреса обязательны к заполнению.
Имя пользователя — имя пользователя для авторизации на proxy-сервере. Если proxy-сервер не требует авторизацию, то имя пользователя не указывается.
Пароль — пароль пользователя для авторизации на proxy-сервере.
4. Дополнительные параметры.
Пассивный режим FTP — установите этот флаг, если обновления расположены на FTP-сервере.
Таймаут — время ожидания ответов от сервера обновлений.

Укажите все необходимые параметры для проверки обновлений и нажмите кнопку Сохранить.


Описание процесса обновления клиентской части

Для запуска процесса поиска обновлений программы выполните следующие действия:

1. Настройте параметры проверки обновлений.
2. Выберите пункт меню ?—Проверка обновлений.

После запуска процедуры проверки обновлений будут выполнены следующие действия:

1. Откроется окно индикации процесса проверки обновлений.

Индикация проверки обновлений
2. С сервера обновлений будет загружен файл описания доступных модулей.
3. Будет проведен анализ полученного файла на предмет необходимости обновления имеющихся модулей программы. Если обновление программы не требуется, то процесс на этом прекратится.
4. Если будут обнаружены обновленные модули, то запустится процедура загрузки этих модулей (на рисунке показан момент начала загрузки 8-го из 46 файлов новой версии).
5. После загрузки всех нужных файлов будет выведен запрос на установку обновлений.

Запрос на установку обновлений
6. Если пользователь откажется от установки обновлений, то процесс будет прерван. Для повторной проверки нужно будет начать процесс сначала.
Если пользователь подтвердит установку обновлений, то на экран будет выведено окно процесса установки обновлений, а программа будет закрыта.

Процесс установки обновлений
7. По окончании установки обновлений на экран будет выведен запрос на запуск программы.

Запрос запуска программы после обновления

Если в организации используется сетевая версия программы и работа с данными ведется с разных компьютеров, то можно провести обновление на одном компьютере, затем скопировать содержимое папки установки программы на остальные компьютеры.


Описание процесса обновления БД

 О программе Назад

Программа поставляется с модулем обновления базы данных, предназначенным для внесения изменений в базу данных.

Файлы обновления базы данных загружаются на рабочую станцию вместе с обновлением клиентской части. При каждом запуске программы производится проверка версии базы данных и поиск в служебной папке программы наличия загруженных обновлений для БД. Если обнаружатся файлы обновления БД до новой версии, то запускается процедура обновления базы данных.

Обновление базы данных следует всегда проводить в монопольном режиме, т.е. при обновлении БД никакие другие рабочие станции не должны быть подключены к базе данных.

При использовании локальной версии данное требование выполняется автоматически. При использовании сетевой версии программы необходимо завершить работу всех рабочих станций кроме той, на которой будет выполняться обновление программы. Затем выполнить обновление на этом рабочем месте. После установки обновлений запустить программу, затем, если потребуется, установить обновление БД, и только после этого обновлять остальные рабочие места.

Итак, если в процессе обновления клиентской части будут загружены обновления БД до новой версии, то при последующем запуске программы на экран будет выведено сообщение о необходимости обновления БД.

Запрос на обновление БД

После подтверждения запустится процедура обновления, которая выполнит следующие действия:

1. Откроет окно лога процесса обновления. (на рисунке зафиксирован конец лога успешного обновления).

Окно процесса обновления

2. Запустится резервное копирование базы данных (на рисунке виден самый конец сообщений gbak — утилиты резервного копирования).
3. По окончании резервного копирования запустится процесс обновления структуры БД.
4. При возникновении ошибки будет запущен процесс восстановления базы из резервной копии по завершении которого в окне сообщений будет указано имя файла с логом всех выполненных операций. Этот файл нужен для анализа возникшей ошибки.
Если обновление выполнится успешно, то на экран будет выведено сообщение о завершении обновления БД.

Обновление БД завершено